summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-02 10:44:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-02 12:00:52 +0100
commit462ddb40a7f7ae59458b59eae34b1e562fd210e4 (patch)
tree77fa4d9bb473a8513b64ce28dd622d9d51d5f73c /app-cdr
parentkde-apps/umbrello: 22.12.2 version bump (diff)
downloadgentoo-462ddb40a7f7ae59458b59eae34b1e562fd210e4.tar.gz
gentoo-462ddb40a7f7ae59458b59eae34b1e562fd210e4.tar.bz2
gentoo-462ddb40a7f7ae59458b59eae34b1e562fd210e4.zip
app-cdr/dolphin-plugins-mountiso: 22.12.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-22.12.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
index f8e896b5cb4a..e4ef543a379d 100644
--- a/app-cdr/dolphin-plugins-mountiso/Manifest
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-22.08.3.tar.xz 260088 BLAKE2B 2927d42a603776cc3b600606ff2f27a77c8bbbe6b089d3e691571c7594d0e4d53023064afbf07e02f546073823a873fd45f200ea13b9e2765b61046602d8239b SHA512 2201858d9d349c28cced78dcfd9a31c3fde05b3ab107a28615af4cc5c32d4315074881f78dfb255638a13269de16ab68b7c53b68d013cf46ded091f8b059173e
DIST dolphin-plugins-22.12.1.tar.xz 268820 BLAKE2B e2468bb550d779d89808a59839f191fc5dd75a0146dfd3a2ba6dac823df8ea62b6425d5ca074b189f5d06e5f461b2edeb49423718e4da767e11edac3e6c35154 SHA512 7f3a3795050371b38e77b726eb74b2c0b0bc777056402a36c3f85e3e58103f2a56d73fa599a45572516aaa2e173f0fc3adf4ced6a5d8aabd4d07939c05deb62c
+DIST dolphin-plugins-22.12.2.tar.xz 271696 BLAKE2B b2a8fecc15ad80f4bdc8ca21517f39354576dac6e81e93a276266d6e2b4d4d09142794972c5b4d09b71019a11aad3f80dd9a07064759c05c0a13ee572980e7d6 SHA512 bc54ceaa845ec5e5493f687cd0c7b3f6a0bab264de5c03f65e219ccd9bbc4c3f348bd48cbb885bea41ed68fd8d0bfc30420f9959bde2bb04b5a37b33210b6667
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-22.12.2.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-22.12.2.ebuild
new file mode 100644
index 000000000000..c8fe96859f8c
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-22.12.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.101.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}