summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-01-30 15:45:21 -0800
committerZac Medico <zmedico@gentoo.org>2022-01-30 15:47:18 -0800
commit2a6d5effd5c9b435563f751a919fefea6810f3d6 (patch)
treed1dce6d11cffb740d69e3e524c9fe795f99fd91d /app-containers/buildah
parentdev-perl/Font-TTF: Keyword 1.60.0-r1 for ~m68k (diff)
downloadgentoo-2a6d5effd5c9b435563f751a919fefea6810f3d6.tar.gz
gentoo-2a6d5effd5c9b435563f751a919fefea6810f3d6.tar.bz2
gentoo-2a6d5effd5c9b435563f751a919fefea6810f3d6.zip
app-containers/buildah: Bump to version 1.24.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/buildah')
-rw-r--r--app-containers/buildah/Manifest1
-rw-r--r--app-containers/buildah/buildah-1.24.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index ae809d0a5131..17d30c060e45 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,2 +1,3 @@
DIST buildah-1.21.1.tar.gz 11693142 BLAKE2B 513f75d8f2831130759f3bcb77fad311c28862b82df8866608bd909eea38468a6b576dfad2598725caa9c4e413108ea6ec3557c8a777017cc8a37b5cb16b70a1 SHA512 8fb30ed0948f898aef9a32c34d4b2a2e04a376257a73184ec01b67c770be1c3c87e46987ad001ececf2235cb5e17f9d0ff9e9f34be61ddd0935859c4e5b37d1f
DIST buildah-1.23.1.tar.gz 11872323 BLAKE2B 6e4cffd11177bca6c3e86cd3372fc7bf295b23559b7478a679ea2bea022c149b5ea058224f0a156df1b9511905795c44ed5e988ec68ca834dd80d0c198543d5f SHA512 2ceb6df5adb671483557bb03937df583857d99c116be5d44aae533c155f560d5d454bebf25908ac02bb85e4c2ba31533adb99f0946ecc4f4830977c14f324b6f
+DIST buildah-1.24.0.tar.gz 14143490 BLAKE2B c9883cc849d8837cdc4d31c02d49138f61b99f97fc40eb36494368eb47f1d74a24c6ddc4f631a043769ecb03906d11978afc7fae993a2f10346d9ac072d6e322 SHA512 337792cb896de3c10a66f7e2cf7c52d0dffd0ca8fede48a4d3a666d2a05e17bb3116db7c20a39805e9360b24a5df12d8ebd7a3818be12bb8e06e4b16cd62fc60
diff --git a/app-containers/buildah/buildah-1.24.0.ebuild b/app-containers/buildah/buildah-1.24.0.ebuild
new file mode 100644
index 000000000000..cc98ed8a4eb2
--- /dev/null
+++ b/app-containers/buildah/buildah-1.24.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+GIT_COMMIT=d9a41b85
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="selinux"
+
+RDEPEND="app-crypt/gpgme:=
+ app-containers/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+ sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin bin/{${PN},imgtype}
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}