summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-06 00:15:20 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-06 00:17:25 -0800
commit8fdda211404b31c7825bcfcd2f2f139c09c90740 (patch)
tree4d7edfe3dda8e03d18c3b1f68e6b76393f6fd73b /app-containers/containerd
parentnet-analyzer/graphite-web-1.1.8: version bump, fix pyparsing interaction (diff)
downloadgentoo-8fdda211404b31c7825bcfcd2f2f139c09c90740.tar.gz
gentoo-8fdda211404b31c7825bcfcd2f2f139c09c90740.tar.bz2
gentoo-8fdda211404b31c7825bcfcd2f2f139c09c90740.zip
app-containers/containerd: add 1.5.9
Bug: https://bugs.gentoo.org/830672 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-containers/containerd')
-rw-r--r--app-containers/containerd/Manifest1
-rw-r--r--app-containers/containerd/containerd-1.5.9.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/app-containers/containerd/Manifest b/app-containers/containerd/Manifest
index afccf8f9a0b7..fd8badebb7dc 100644
--- a/app-containers/containerd/Manifest
+++ b/app-containers/containerd/Manifest
@@ -1,3 +1,4 @@
DIST containerd-1.4.11.tar.gz 6406769 BLAKE2B a4882223e2f71944a4d46fb0500a95248cfa33735447952f94c7d7350c2cb62b4911adc77f96559116cca462be02b7270185a0a3dfed5ce4c530465cca7e2078 SHA512 16aa6ae4209939754e122545b454d8b25027a3621464a4b4e0379480b35adf0efb318271f82cf2b959a62fffe531979c9bdfee9ac7d47d4b33269a6bafe2d070
DIST containerd-1.4.12.tar.gz 6408402 BLAKE2B 559164a9d8680edea52040690da8e9b45777a39e471b1a7cc56ff4cf207cee7c83dc73969a8868db5d531f6e4e27cc7a975f073ffcf7f9c2768858b1a4001ddf SHA512 52dc4b0344eb4c6a6f1cc5690ff0c70ee052ef05c02300ed4a806458c40bb1970c26b374b0733b2c30a05c04a731d62a7c4206b1d768075d51c202912efd32b1
DIST containerd-1.5.7.tar.gz 7714453 BLAKE2B 621b6527814665432c52e72263da371840a183aa65f621a686111b59ee48e85dd96919abd35f069476b97858a8112d3c92b03afbe42d57495649ca0d2af2fd50 SHA512 ce0d9d355b4a6142569690a9fcde8cd07de20b5788098f1184a728106a60dd11a437c87499a97af0c147b14372c2bca4daa823ea470f10b5e1b8a1e34ba530b0
+DIST containerd-1.5.9.tar.gz 7695248 BLAKE2B 1bbd755cadee9022671e6340a194c7190b7249001b56128cb6a94982d83c01dc9292e08ab591728fa223523d7488bed63d055ce0b552196cf4d1c7dfb41928b5 SHA512 13d5b8bcfd811b1abf67008d1c664962f315cd45d885adaa88847bcc4f1c5d743dccd62bc34fe77348ca18a4f8841ce7a8a022cccb275b19b59017b3fbf1054b
diff --git a/app-containers/containerd/containerd-1.5.9.ebuild b/app-containers/containerd/containerd-1.5.9.ebuild
new file mode 100644
index 000000000000..8c3ca72bdc9c
--- /dev/null
+++ b/app-containers/containerd/containerd-1.5.9.ebuild
@@ -0,0 +1,84 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GIT_REVISION=1407cab509ff0d96baa4f0eb6ff9980270e6e620
+inherit go-module systemd
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.io/"
+SRC_URI="https://github.com/containerd/containerd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
+
+DEPEND="
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )
+"
+
+# recommended version of runc is found in script/setup/runc-version
+RDEPEND="
+ ${DEPEND}
+ ~app-containers/runc-1.0.3
+"
+
+BDEPEND="
+ dev-go/go-md2man
+ virtual/pkgconfig
+"
+
+# tests require root or docker
+# upstream does not recommend stripping binary
+RESTRICT+=" strip test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/-s -w//" \
+ Makefile || die
+ sed -i \
+ -e "s:/usr/local:/usr:" \
+ containerd.service || die
+}
+
+src_compile() {
+ local options=(
+ $(usev apparmor)
+ $(usex btrfs "" "no_btrfs")
+ $(usex cri "" "no_cri")
+ $(usex device-mapper "" "no_devmapper")
+ $(usev seccomp)
+ $(usev selinux)
+ )
+
+ myemakeargs=(
+ BUILDTAGS="${options[*]}"
+ LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')"
+ REVISION="${GIT_REVISION}"
+ VERSION=v${PV}
+ )
+
+ # race condition in man target https://bugs.gentoo.org/765100
+ # we need to explicitly specify GOFLAGS for "go run" to use vendor source
+ emake "${myemakeargs[@]}" man -j1 #nowarn
+ emake "${myemakeargs[@]}" all
+
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+ newinitd "${FILESDIR}"/${PN}.initd "${PN}"
+ systemd_dounit containerd.service
+ keepdir /var/lib/containerd
+
+ # we already installed manpages, remove markdown source
+ # before installing docs directory
+ rm -r docs/man || die
+
+ local DOCS=( ADOPTERS.md README.md RELEASES.md ROADMAP.md SCOPE.md docs/. )
+ einstalldocs
+}