summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-09-24 16:19:19 +0530
committerZac Medico <zmedico@gentoo.org>2023-09-24 20:45:17 -0700
commit275aeff423d63b6cdde5b508f59d5af5248f16c0 (patch)
tree33d45bd42d246702fedee759718aaff34ce7cf25 /app-containers/containers-common
parentapp-containers/podman: drop 4.3.1 & 4.4.1 (diff)
downloadgentoo-275aeff423d63b6cdde5b508f59d5af5248f16c0.tar.gz
gentoo-275aeff423d63b6cdde5b508f59d5af5248f16c0.tar.bz2
gentoo-275aeff423d63b6cdde5b508f59d5af5248f16c0.zip
app-containers/podman: add 4.5.0-r1
few improvements to ebuild. 1) use shell-completion.eclass replacing bash-completino-r1 2) add app-containers/containers-common as dep & adjust other deps 3) dont install seccomp.json,policy.json,registries.conf as it is installed by containers-common 4) removed non-amd64 keywords as containers-common is only available on amd64 for now I'll soon be working on podman version bump with live version too. Closes: https://github.com/gentoo/gentoo/pull/33030 Closes: https://bugs.gentoo.org/902569 Closes: https://bugs.gentoo.org/849863 Closes: https://bugs.gentoo.org/914597 Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/containers-common')
-rw-r--r--app-containers/containers-common/containers-common-0.56.0-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-containers/containers-common/containers-common-0.56.0-r1.ebuild b/app-containers/containers-common/containers-common-0.56.0-r1.ebuild
new file mode 100644
index 000000000000..73407d6e4994
--- /dev/null
+++ b/app-containers/containers-common/containers-common-0.56.0-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Common config files and docs for Containers eco-system"
+HOMEPAGE="https://github.com/containers/common"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/common.git"
+else
+ SRC_URI="https://github.com/containers/common/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ app-containers/containers-image
+ app-containers/containers-storage
+ app-containers/containers-shortnames
+ !<app-containers/podman-4.5.0-r1
+ net-firewall/nftables
+ net-firewall/iptables[nftables]
+ || ( app-containers/crun app-containers/runc )
+ || (
+ ( >=app-containers/netavark-1.6.0 >=app-containers/aardvark-dns-1.6.0 )
+ >=app-containers/cni-plugins-0.9.1
+ )
+"
+
+BDEPEND="
+ >=dev-go/go-md2man-2.0.2
+"
+
+src_prepare() {
+ default
+
+ [[ -f docs/Makefile ]] || die
+ sed -i -e 's|/usr/local|/usr|g;' docs/Makefile || die
+
+ eapply "${FILESDIR}/fix-warnings.patch"
+ eapply "${FILESDIR}/examplify-mounts-conf.patch"
+}
+
+src_compile() {
+ emake docs
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/containers
+ # https://github.com/containers/skopeo/raw/main/default-policy.json
+ doins pkg/config/containers.conf "${FILESDIR}/policy.json"
+
+ insinto /etc/containers/registries.d
+ # https://github.com/containers/skopeo/raw/main/default.yaml
+ doins "${FILESDIR}/default.yaml"
+
+ insinto /usr/share/containers
+ doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
+
+ keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
+}