summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-07-27 19:10:56 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-07-27 19:14:48 -0500
commit70907ff4c71a8f9f737d3255fc399fd76e599092 (patch)
tree25ef6a1449825502e2f51ab57b1c4ba82c0c53d8 /app-containers/cosign
parentmedia-gfx/gmic: drop := from dev-qt dependencies (diff)
downloadgentoo-70907ff4c71a8f9f737d3255fc399fd76e599092.tar.gz
gentoo-70907ff4c71a8f9f737d3255fc399fd76e599092.tar.bz2
gentoo-70907ff4c71a8f9f737d3255fc399fd76e599092.zip
app-containers/cosign: remove the goimports calls
Add a patch from upstream for this bug. Closes: https://bugs.gentoo.org/859208 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/cosign')
-rw-r--r--app-containers/cosign/cosign-1.10.0.ebuild4
-rw-r--r--app-containers/cosign/files/cosign-1.10.0-fix-makefile.patch40
2 files changed, 44 insertions, 0 deletions
diff --git a/app-containers/cosign/cosign-1.10.0.ebuild b/app-containers/cosign/cosign-1.10.0.ebuild
index 194effdf1cd3..7adb2e5ed8d1 100644
--- a/app-containers/cosign/cosign-1.10.0.ebuild
+++ b/app-containers/cosign/cosign-1.10.0.ebuild
@@ -16,6 +16,10 @@ KEYWORDS="~amd64"
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-makefile.patch
+)
+
src_compile() {
emake \
GIT_HASH=${GIT_HASH} \
diff --git a/app-containers/cosign/files/cosign-1.10.0-fix-makefile.patch b/app-containers/cosign/files/cosign-1.10.0-fix-makefile.patch
new file mode 100644
index 000000000000..5699bca5732c
--- /dev/null
+++ b/app-containers/cosign/files/cosign-1.10.0-fix-makefile.patch
@@ -0,0 +1,40 @@
+diff --git a/Makefile b/Makefile
+index 3b6dcb5..8981549 100644
+--- a/Makefile
++++ b/Makefile
+@@ -20,8 +20,6 @@ else
+ GOBIN=$(shell go env GOBIN)
+ endif
+
+-GOFILES ?= $(shell find . -type f -name '*.go' -not -path "./vendor/*")
+-
+ # Set version variables for LDFLAGS
+ PROJECT_ID ?= projectsigstore
+ RUNTIME_IMAGE ?= gcr.io/distroless/static
+@@ -72,18 +70,6 @@ log-%:
+ printf "\033[36m==> %s\033[0m\n", $$2 \
+ }'
+
+-.PHONY: checkfmt
+-checkfmt: SHELL := /usr/bin/env bash
+-checkfmt: ## Check formatting of all go files
+- @ $(MAKE) --no-print-directory log-$@
+- $(shell test -z "$(shell gofmt -l $(GOFILES) | tee /dev/stderr)")
+- $(shell test -z "$(shell goimports -l $(GOFILES) | tee /dev/stderr)")
+-
+-.PHONY: fmt
+-fmt: ## Format all go files
+- @ $(MAKE) --no-print-directory log-$@
+- goimports -w $(GOFILES)
+-
+ cosign: $(SRCS)
+ CGO_ENABLED=0 go build -trimpath -ldflags "$(LDFLAGS)" -o $@ ./cmd/cosign
+
+@@ -121,7 +107,6 @@ clean:
+ rm -rf sget
+ rm -rf dist/
+
+-
+ KOCACHE_PATH=/tmp/ko
+ ARTIFACT_HUB_LABELS=--image-label io.artifacthub.package.readme-url="https://raw.githubusercontent.com/sigstore/cosign/main/README.md" \
+ --image-label io.artifacthub.package.logo-url=https://raw.githubusercontent.com/sigstore/cosign/main/images/logo.svg \