summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-19 23:30:04 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-20 00:51:32 -0800
commit36286e6d06e223f2412757f408d9f77dde0fdc41 (patch)
tree023955f8f1b8a6cfb1aa1a8238d922cce2108ea8 /app-containers/cri-tools/cri-tools-1.21.0.ebuild
parentMove {app-emulation -> app-containers}/cri-o (diff)
downloadgentoo-36286e6d06e223f2412757f408d9f77dde0fdc41.tar.gz
gentoo-36286e6d06e223f2412757f408d9f77dde0fdc41.tar.bz2
gentoo-36286e6d06e223f2412757f408d9f77dde0fdc41.zip
Move {app-emulation -> app-containers}/cri-tools
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-containers/cri-tools/cri-tools-1.21.0.ebuild')
-rw-r--r--app-containers/cri-tools/cri-tools-1.21.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/cri-tools/cri-tools-1.21.0.ebuild b/app-containers/cri-tools/cri-tools-1.21.0.ebuild
new file mode 100644
index 000000000000..b171220105c3
--- /dev/null
+++ b/app-containers/cri-tools/cri-tools-1.21.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
+HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
+SRC_URI="https://github.com/kubernetes-sigs/cri-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+
+DEPEND="dev-lang/go"
+
+RESTRICT+=" test"
+
+src_compile() {
+ emake VERSION="${PV}"
+ ./build/bin/crictl completion bash > "${PN}.bash" || die
+ ./build/bin/crictl completion zsh > "${PN}.zsh" || die
+}
+
+src_install() {
+ dobin ./build/bin/crictl
+
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ dodoc -r docs {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
+}