summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-26 03:43:15 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-26 03:43:15 +0200
commit207599796d46b101a0ed571078ebee4c2f4600f8 (patch)
treee07bc6ecfeb37d1377f6b6be7686ca392c2c43b8 /app-containers/distrobox/distrobox-9999.ebuild
parentapp-text/xapian-omega: version bump 1.4.21 (diff)
downloadgentoo-207599796d46b101a0ed571078ebee4c2f4600f8.tar.gz
gentoo-207599796d46b101a0ed571078ebee4c2f4600f8.tar.bz2
gentoo-207599796d46b101a0ed571078ebee4c2f4600f8.zip
app-containers/distrobox: rename from app-emulation/distrobox
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers/distrobox/distrobox-9999.ebuild')
-rw-r--r--app-containers/distrobox/distrobox-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-containers/distrobox/distrobox-9999.ebuild b/app-containers/distrobox/distrobox-9999.ebuild
new file mode 100644
index 000000000000..f3fc5a365796
--- /dev/null
+++ b/app-containers/distrobox/distrobox-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}"/usr || die "${PN} install script failed"
+ dodoc *.md
+}