summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-07-24 16:26:27 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-07-24 16:26:27 -0500
commit1485ee097f10ade3b68b5b0ba05d1c4cde000704 (patch)
tree1a03869c1bd10a71f663144b0e3c042c3f92952d /app-containers/runc
parentapp-containers/containerd: drop 1.6.20, 1.7.1 (diff)
downloadgentoo-1485ee097f10ade3b68b5b0ba05d1c4cde000704.tar.gz
gentoo-1485ee097f10ade3b68b5b0ba05d1c4cde000704.tar.bz2
gentoo-1485ee097f10ade3b68b5b0ba05d1c4cde000704.zip
app-containers/runc: drop 1.1.5
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/runc')
-rw-r--r--app-containers/runc/Manifest1
-rw-r--r--app-containers/runc/runc-1.1.5.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/app-containers/runc/Manifest b/app-containers/runc/Manifest
index a3082d620465..258b36fe4190 100644
--- a/app-containers/runc/Manifest
+++ b/app-containers/runc/Manifest
@@ -1,3 +1,2 @@
DIST runc-1.1.4.tar.gz 2334639 BLAKE2B bc7eb7de29e8ebb9ce146bc77bf6cfc116f4af3e28c0344059183cf0c8082c629ccb235531c368cce99915991b25df0b50b7cbb98b9c6a7d141ba6cc15958651 SHA512 c8e79ad839964680d29ab56a4de255f91192741951673025da6889c544a232d4d392db2da8005d8e22999a37bfbc9c9fe7f6043b165bc4edc2f2a29261d8a3d6
-DIST runc-1.1.5.tar.gz 2336539 BLAKE2B 3fcc4c2160f33fcec2efd6bcd755279c535128af870d4ea71dc07c501c0f401f394f2f66219739ca24cc5ec37b5944b0323f8e7ee49c619513ce826159e3a395 SHA512 f3cc9b93b0fe8a4341d410010fe584febb8e975ec9e0fd569d7dff33ab74c5821a2e0c40b7aeafd6b90991a50eae9c352342437f09cf6884dc850ceccdc68944
DIST runc-1.1.7.tar.gz 2511464 BLAKE2B 63f09052659636b62185abbb178f7e104d22125190899e80e71ed2ba35567eb855abf786d3c7fff3dd9a1ab43ee282fcaecb6650cd8a1ce49c05acefd7c12cde SHA512 e3a18f04ac2c3553a815074ca64e04cfd71af54d78edbd4a13819f187476f96d7311c23bb63fb5c311b91865db4540985a6f9daa84819b0bac5f023b3b2a832c
diff --git a/app-containers/runc/runc-1.1.5.ebuild b/app-containers/runc/runc-1.1.5.ebuild
deleted file mode 100644
index 83e98084e2e8..000000000000
--- a/app-containers/runc/runc-1.1.5.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module linux-info
-
-# update on bump, look for https://github.com/docker\
-# docker-ce/blob/<docker ver OR branch>/components/engine/hack/dockerfile/install/runc.installer
-RUNC_COMMIT=f19387a6bec4944c770f7668ab51c4348d9c2f38
-CONFIG_CHECK="~USER_NS"
-
-DESCRIPTION="runc container cli tools"
-HOMEPAGE="http://github.com/opencontainers/runc/"
-MY_PV="${PV/_/-}"
-SRC_URI="https://github.com/opencontainers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 BSD MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="apparmor hardened +kmem +seccomp selinux test"
-
-DEPEND="seccomp? ( sys-libs/libseccomp )"
-
-RDEPEND="
- ${DEPEND}
- !app-emulation/docker-runc
- apparmor? ( sys-libs/libapparmor )
- selinux? ( sec-policy/selinux-container )
-"
-
-BDEPEND="
- dev-go/go-md2man
- test? ( "${RDEPEND}" )
-"
-
-# tests need busybox binary, and portage namespace
-# sandboxing disabled: mount-sandbox pid-sandbox ipc-sandbox
-# majority of tests pass
-RESTRICT+=" test"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_compile() {
- # Taken from app-containers/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ESYSROOT}/usr/$(get_libdir)"
-
- # build up optional flags
- local options=(
- $(usev apparmor)
- $(usev seccomp)
- $(usex kmem '' 'nokmem')
- )
-
- myemakeargs=(
- BUILDTAGS="${options[*]}"
- COMMIT="${RUNC_COMMIT}"
- )
-
- emake "${myemakeargs[@]}" runc man
-}
-
-src_install() {
- myemakeargs+=(
- PREFIX="${ED}/usr"
- BINDIR="${ED}/usr/bin"
- MANDIR="${ED}/usr/share/man"
- )
- emake "${myemakeargs[@]}" install install-man install-bash
-
- local DOCS=( README.md PRINCIPLES.md docs/. )
- einstalldocs
-}
-
-src_test() {
- emake "${myemakeargs[@]}" localunittest
-}