summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-05-07 09:19:27 -0700
committerZac Medico <zmedico@gentoo.org>2022-05-07 09:22:15 -0700
commitee029384538a6cd1c16c501e66dc46dbccefe67f (patch)
treefb7a199a4e95b07679c740f95c06adf98a9400ce /app-containers/skopeo/skopeo-1.1.0.ebuild
parentsci-mathematics/octave: don't install *.la files. (diff)
downloadgentoo-ee029384538a6cd1c16c501e66dc46dbccefe67f.tar.gz
gentoo-ee029384538a6cd1c16c501e66dc46dbccefe67f.tar.bz2
gentoo-ee029384538a6cd1c16c501e66dc46dbccefe67f.zip
app-containers/skopeo: drop versions
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/skopeo/skopeo-1.1.0.ebuild')
-rw-r--r--app-containers/skopeo/skopeo-1.1.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/app-containers/skopeo/skopeo-1.1.0.ebuild b/app-containers/skopeo/skopeo-1.1.0.ebuild
deleted file mode 100644
index 7a625ebb1c56..000000000000
--- a/app-containers/skopeo/skopeo-1.1.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-COMMIT=63085f5bef1131aa9ec0907a5c8d66b67de7c4b2
-inherit go-module bash-completion-r1
-
-DESCRIPTION="Command line utility foroperations on container images and image repositories"
-HOMEPAGE="https://github.com/containers/skopeo"
-SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="btrfs"
-
-COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
- >=dev-libs/libassuan-2.4.3:=
- dev-libs/libgpg-error:=
- btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
- >=sys-fs/lvm2-2.02.145:="
-DEPEND="${COMMON_DEPEND}
- dev-go/go-md2man"
-RDEPEND="${COMMON_DEPEND}"
-
-RESTRICT="test"
-
-src_compile() {
- local BUILDTAGS
- BUILDTAGS="containers_image_ostree_stub $(usex btrfs "" exclude_graphdriver_btrfs)"
- set -- go build -mod=vendor -ldflags "-X main.gitCommit=${COMMIT}" \
- -gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
- -o skopeo ./cmd/skopeo
- echo "$@"
- "$@" || die
- cd docs || die
- for f in *.1.md; do
- go-md2man -in ${f} -out ${f%%.md} || die
- done
-}
-
-src_install() {
- dobin skopeo
- doman docs/*.1
- dobashcomp completions/bash/skopeo
- insinto /etc/containers
- newins default-policy.json policy.json
- insinto /etc/containers/registries.d
- doins default.yaml
- keepdir /var/lib/atomic/sigstore
- einstalldocs
-}