summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-03-23 15:14:20 +0530
committerZac Medico <zmedico@gentoo.org>2024-03-26 19:34:34 -0700
commit097f59065b071ff3f8bbc97e3ab4a35e233560ee (patch)
tree84ac4a9b26488bd61688582241d24ee61b2a485f /app-containers
parentsys-devel/clang-common: stable 15.0.7-r8, 16.0.6-r3, 17.0.6-r3 (diff)
downloadgentoo-097f59065b071ff3f8bbc97e3ab4a35e233560ee.tar.gz
gentoo-097f59065b071ff3f8bbc97e3ab4a35e233560ee.tar.bz2
gentoo-097f59065b071ff3f8bbc97e3ab4a35e233560ee.zip
app-containers/buildah: fix calling as directly
Closes: https://bugs.gentoo.org/924038 Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> From: https://github.com/gentoo/gentoo/pull/35931 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/buildah/buildah-1.33.7.ebuild3
-rw-r--r--app-containers/buildah/buildah-1.34.3.ebuild3
-rw-r--r--app-containers/buildah/buildah-1.35.1.ebuild5
-rw-r--r--app-containers/buildah/buildah-9999.ebuild3
4 files changed, 9 insertions, 5 deletions
diff --git a/app-containers/buildah/buildah-1.33.7.ebuild b/app-containers/buildah/buildah-1.33.7.ebuild
index d2df0195c32a..f100d2a5a83a 100644
--- a/app-containers/buildah/buildah-1.33.7.ebuild
+++ b/app-containers/buildah/buildah-1.33.7.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit go-module linux-info
+inherit go-module linux-info toolchain-funcs
DESCRIPTION="A tool that facilitates building OCI images"
HOMEPAGE="https://github.com/containers/buildah"
@@ -109,6 +109,7 @@ src_compile() {
# https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
+ tc-export AS LD
default
}
diff --git a/app-containers/buildah/buildah-1.34.3.ebuild b/app-containers/buildah/buildah-1.34.3.ebuild
index d2df0195c32a..f100d2a5a83a 100644
--- a/app-containers/buildah/buildah-1.34.3.ebuild
+++ b/app-containers/buildah/buildah-1.34.3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit go-module linux-info
+inherit go-module linux-info toolchain-funcs
DESCRIPTION="A tool that facilitates building OCI images"
HOMEPAGE="https://github.com/containers/buildah"
@@ -109,6 +109,7 @@ src_compile() {
# https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
+ tc-export AS LD
default
}
diff --git a/app-containers/buildah/buildah-1.35.1.ebuild b/app-containers/buildah/buildah-1.35.1.ebuild
index 8d0698568fd3..f5596936ec24 100644
--- a/app-containers/buildah/buildah-1.35.1.ebuild
+++ b/app-containers/buildah/buildah-1.35.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit go-module linux-info
+inherit go-module linux-info toolchain-funcs
DESCRIPTION="A tool that facilitates building OCI images"
HOMEPAGE="https://github.com/containers/buildah"
@@ -35,7 +35,7 @@ RDEPEND="
btrfs? ( sys-fs/btrfs-progs )
seccomp? ( sys-libs/libseccomp:= )
apparmor? ( sys-libs/libapparmor:= )
- app-containers/containers-common
+ >=app-containers/containers-common-0.58.0-r1
app-crypt/gpgme:=
dev-libs/libgpg-error:=
dev-libs/libassuan:=
@@ -109,6 +109,7 @@ src_compile() {
# https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
+ tc-export AS LD
default
}
diff --git a/app-containers/buildah/buildah-9999.ebuild b/app-containers/buildah/buildah-9999.ebuild
index e8ee0949a819..f5596936ec24 100644
--- a/app-containers/buildah/buildah-9999.ebuild
+++ b/app-containers/buildah/buildah-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit go-module linux-info
+inherit go-module linux-info toolchain-funcs
DESCRIPTION="A tool that facilitates building OCI images"
HOMEPAGE="https://github.com/containers/buildah"
@@ -109,6 +109,7 @@ src_compile() {
# https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
+ tc-export AS LD
default
}