summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-03-21 14:17:37 +0530
committerSam James <sam@gentoo.org>2024-03-23 08:29:04 +0000
commit173217ead110a21276e53e4999f4a158ff0751e7 (patch)
tree545cd5ce92846e19b3893a1e0c4ab422b7f1f7c2 /app-containers
parentapp-containers/podman: update to 5.0.0 (diff)
downloadgentoo-173217ead110a21276e53e4999f4a158ff0751e7.tar.gz
gentoo-173217ead110a21276e53e4999f4a158ff0751e7.tar.bz2
gentoo-173217ead110a21276e53e4999f4a158ff0751e7.zip
app-containers/podman-tui: add 1.0.0
Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/podman-tui/Manifest1
-rw-r--r--app-containers/podman-tui/podman-tui-1.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/podman-tui/Manifest b/app-containers/podman-tui/Manifest
index 2ddbb2eb02b0..8c13a661d10e 100644
--- a/app-containers/podman-tui/Manifest
+++ b/app-containers/podman-tui/Manifest
@@ -1,3 +1,4 @@
DIST podman-tui-0.14.0.tar.gz 15857429 BLAKE2B c1a6f056b45d4fa9e0cd749570275da1d98d3f8477a1e85a151afd1cecc9506555c55e065b86d9c49acde36a27c3dac960530218022672fc8044dee0d2284c62 SHA512 d79e5b0cabed6873ff90e4e36fec841b74d53b0e876f6449c9b5512c8a92d7d4bcf733e23abc92a6344d6dcd72957929fde48b4e16dcb1cc33cf10f33074171a
DIST podman-tui-0.17.0.tar.gz 15853215 BLAKE2B bfdaf085837497c8ce1525eccb04fc977472291e45417a3993a3e9bc2a742e132d14bce7580c0126be94262a10999da2b81edd6997b8c377a3de8a4da20c153f SHA512 137740737e4fe5138198923fb5db6dc6ca901ed7739af09c19bcb0a60fdfe0db79d7c2ac83157675ec478ab8e9dc9b1348cd8aa9f0e5298f8d20ff6cf0284afc
DIST podman-tui-0.18.0.tar.gz 15928626 BLAKE2B 80fd4f826a407b4eeeb664c065f836f12dd85cacab35003ad8fbcabf3eb69b3838bf02fb76269124d18c110370e42556cff8e348caabb100aa88a1994f99d4cc SHA512 77107a9e64b12fd5065698b7065909d5aa45ca49d749056cfb0f76aa2fd0f269708d3d75ecb4cab7939c30571510cdacebcdaac67549979873e3656e1af4db9f
+DIST podman-tui-1.0.0.tar.gz 16208356 BLAKE2B c5ae4274cdc6c4d5abb9f9a18c82949a40a9f2894a9127d8bdf89b8a9445716cc985d8400833c890dec4524fd617babd5791e3062e9e7654ea93d66c34dfe181 SHA512 918b3efb823a543a439ae0f56c59ee2689961ac6e39a40054a7971ddf02056ca50c7c681ca03c45590e9fdfce1822f406bbf90f9b25563a0ef9ae75b88235a8c
diff --git a/app-containers/podman-tui/podman-tui-1.0.0.ebuild b/app-containers/podman-tui/podman-tui-1.0.0.ebuild
new file mode 100644
index 000000000000..beefef11ab58
--- /dev/null
+++ b/app-containers/podman-tui/podman-tui-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+DESCRIPTION="Terminal UI frontend for Podman"
+HOMEPAGE="https://github.com/containers/podman-tui"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
+else
+ SRC_URI="https://github.com/containers/podman-tui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+RESTRICT="test"
+
+src_compile() {
+ # parse tags from Makefile & make them comma-seperated as space-seperated list is deprecated
+ local BUILDTAGS=$(grep 'BUILDTAGS :=' Makefile | awk -F\" '{ print $2; }' | sed -e 's| |,|g;')
+ ego build -tags "${BUILDTAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}