summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-11-23 18:39:04 -0800
committerZac Medico <zmedico@gentoo.org>2022-11-23 18:39:53 -0800
commit1c5e881d991d714025401284af849a46275ad033 (patch)
tree0ce91bb8b71aebf120ff03f205a508c38d4ae24b /app-containers
parentdev-util/ostree: add 2022.7 (diff)
downloadgentoo-1c5e881d991d714025401284af849a46275ad033.tar.gz
gentoo-1c5e881d991d714025401284af849a46275ad033.tar.bz2
gentoo-1c5e881d991d714025401284af849a46275ad033.zip
app-containers/buildah: add 1.28.1
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/buildah/Manifest1
-rw-r--r--app-containers/buildah/buildah-1.28.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index 29d9c97b7194..b75b3bc0ab0d 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,2 +1,3 @@
DIST buildah-1.27.1.tar.gz 14825932 BLAKE2B bf290eeb4d96d255c7cdaa07af49eff44191664ac7dee255c7979656383daaa93c3673ba82ac1cbff033de769ffa08ad027f5d91c81b08a36222cb73e8a1e399 SHA512 a5e2ddf837e613554ffe8fe9c15ac9c8f9c2564c403e5544df7fb8802962581fb4e9dd4361c28c93443ede74c20c82f1631990e443c7895a3b4c3b8a659ee05a
DIST buildah-1.28.0.tar.gz 14579386 BLAKE2B effc7d0a154e30790585c19e19655f98026c34687e79b91777700bc2f387b96896d88855cd5ec34573dd2678e4a30a832c39f789d53b61b45cb5f682dacd252e SHA512 f5e82a22648fa0d0ba7f5dcf3b97a2ec1182f31d3e03cd2624e01fe76fcdddf0a5605c59816eeef6401d151864b6b6be493c144b83f5667ab3947eea902f0086
+DIST buildah-1.28.1.tar.gz 14576193 BLAKE2B 5317b991780b0c2539802495a2a15e91d4e1623700d0a3fa354e362bd647e59a0e9c34d8f19858e129d0028c71bb04665bde7668e3b5f3f3e5b85c944f7108b5 SHA512 c674a90a0cae2977b76c2b68c06a0006f89d74b5b41362c2512a3f8d7ba515c3bd693648a0ba955dad7bea1a43da6890d80855e1283f0fc0136d16d77a798fba
diff --git a/app-containers/buildah/buildah-1.28.1.ebuild b/app-containers/buildah/buildah-1.28.1.ebuild
new file mode 100644
index 000000000000..2f45f2079a30
--- /dev/null
+++ b/app-containers/buildah/buildah-1.28.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+GIT_COMMIT=d3d40a42
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="selinux"
+
+RDEPEND="app-crypt/gpgme:=
+ app-containers/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+ sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin bin/{${PN},imgtype}
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}