summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-03-05 18:56:02 +0530
committerZac Medico <zmedico@gentoo.org>2024-03-18 17:50:22 -0700
commit28db69152d03a02dbc282d99b375fab35b848cde (patch)
tree258efbbd61adf78f31349a9ecc9d886b28a13819 /app-containers
parentprofiles/base: unmask py312 from pytest-s-f (bug #927142) (diff)
downloadgentoo-28db69152d03a02dbc282d99b375fab35b848cde.tar.gz
gentoo-28db69152d03a02dbc282d99b375fab35b848cde.tar.bz2
gentoo-28db69152d03a02dbc282d99b375fab35b848cde.zip
app-containers/containers-image: add 5.30.0
1) revert to using old patch as Makefile is executing command `go` Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/35629 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/containers-image/Manifest1
-rw-r--r--app-containers/containers-image/containers-image-5.30.0.ebuild37
-rw-r--r--app-containers/containers-image/containers-image-9999.ebuild2
3 files changed, 39 insertions, 1 deletions
diff --git a/app-containers/containers-image/Manifest b/app-containers/containers-image/Manifest
index 9e3ed9a8d5a9..0a452993112f 100644
--- a/app-containers/containers-image/Manifest
+++ b/app-containers/containers-image/Manifest
@@ -1,2 +1,3 @@
DIST containers-image-5.29.0.tar.gz 706774 BLAKE2B 0af5c7c43e8b75df591cbd291d0865ac19322bf62ad98b4f36cfb51b006ced088f91f0b3f582ce29ae80582e72087467cfe589683216eeb50ad3762152853dc0 SHA512 5e670f85fe0b43769667f1a3e710434ab65c4ec2d8c60b0cad4b0ed41c35f84677528f9dfecb0b946de556ebbdd56f4949760432ec49b1b3c691120a323af869
DIST containers-image-5.29.2.tar.gz 707618 BLAKE2B f1556cbb26ceedd74a338355caf8b557c43286726f4be63544cebc9a8f4b92be78d7a0cddbedaba7352d13e9fc399f62ee114caba6c8b1ecc334dab1379e523b SHA512 f3f6e09670dc393067992a78303f01e2584dabe79ba156973a50d7a460c011e5a27d0ccdf0ff6b399099a9a3a4c57f3badf24fb5d0704efd645ab7196a544d8f
+DIST containers-image-5.30.0.tar.gz 719070 BLAKE2B 5952ab703b6df793f326dd4fc82f50c5f672e2b9d142e0bc706014092420e3563599d9f1c1f65f743e1a8144b91f92b2326d7bf4c3024b5efb466d777a8ad613 SHA512 89cd0d482bb5d70037ff51413b7abca01d36bc7f39e9dc130c78462e501dae32193137a367d81532afd216a7432e127728147e6e839d5d99eeb6b6680f31d4dc
diff --git a/app-containers/containers-image/containers-image-5.30.0.ebuild b/app-containers/containers-image/containers-image-5.30.0.ebuild
new file mode 100644
index 000000000000..f4507f8d00cf
--- /dev/null
+++ b/app-containers/containers-image/containers-image-5.30.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Default config and docs related to Containers' images"
+HOMEPAGE="https://github.com/containers/image"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/image.git"
+else
+ SRC_URI="https://github.com/containers/image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# https://github.com/gentoo/gentoo/pull/35012#discussion_r1473740969
+RESTRICT='test'
+BDEPEND=">=dev-go/go-md2man-2.0.3"
+PATCHES=(
+ "${FILESDIR}"/fix-warnings.patch
+)
+
+src_compile() {
+ emake docs
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ insinto /etc/containers
+ doins registries.conf
+}
diff --git a/app-containers/containers-image/containers-image-9999.ebuild b/app-containers/containers-image/containers-image-9999.ebuild
index 2df39141c68d..f4507f8d00cf 100644
--- a/app-containers/containers-image/containers-image-9999.ebuild
+++ b/app-containers/containers-image/containers-image-9999.ebuild
@@ -22,7 +22,7 @@ SLOT="0"
RESTRICT='test'
BDEPEND=">=dev-go/go-md2man-2.0.3"
PATCHES=(
- "${FILESDIR}"/prevent-downloading-mods-5.29.2.patch
+ "${FILESDIR}"/fix-warnings.patch
)
src_compile() {