summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-10-20 11:18:03 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-10-20 11:18:03 -0500
commit44ce51cebe45ca8558313399ffb6bfe77425632d (patch)
tree261efba1f04756c22704e4ec662d7647eac3b79d /app-containers
parentsys-apps/portage: drop 3.0.30-r3, 3.0.30-r5, 3.0.37 (diff)
downloadgentoo-44ce51cebe45ca8558313399ffb6bfe77425632d.tar.gz
gentoo-44ce51cebe45ca8558313399ffb6bfe77425632d.tar.bz2
gentoo-44ce51cebe45ca8558313399ffb6bfe77425632d.zip
app-containers/syft: add 0.59.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/syft/Manifest2
-rw-r--r--app-containers/syft/syft-0.59.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
index ba8095a63085..dfc4c6e5e212 100644
--- a/app-containers/syft/Manifest
+++ b/app-containers/syft/Manifest
@@ -4,3 +4,5 @@ DIST syft-0.53.4-deps.tar.xz 668995648 BLAKE2B a2120e677e1438ea8dc369939c157dcdf
DIST syft-0.53.4.tar.gz 3765398 BLAKE2B 15abe368451c14dc0afa9c0d63cdd10d056c0b09f906478188c772241750e0d9e903bd0efe55d87c0c04c4a5a21fa5bc3e1e63b0115e2b24e068d0a52e68b560 SHA512 9267e45165b860540a89ad6c317351abe26d3089294ec9698fa26b37c4413581424f43aae3f01a111b68806c6de30e8464fce27eda1b1cba442e1e0f613843c5
DIST syft-0.54.0-deps.tar.xz 667262532 BLAKE2B f81c3bb54be16c40f3ec811d42c307ef0bf917a06f9f2925b7cce4a1f595092d9efbb7cb20a98a0a0672ca95c257117b2f3da29849fdec453ea054552019cc24 SHA512 e774abcec8786c2c655aa2a369206c79911ea4c706c281c96fb82ec1482c500deb1058bd353a1b107f783eaa41532efdb7a7d50c14c873d612716dc9d8503c57
DIST syft-0.54.0.tar.gz 3770999 BLAKE2B f33679764fc1904b08f9112a3bfa10f6b8e4ab16c3e1bde81283ad7feede92d9eccf04cd6734dbe11f2d838c0ed45f6a62006f5670eea7271428bae45d5ff55c SHA512 c92991c4c48e60101b55a163506abd89b36f6b80312f9ca3f9953027ba7145dd4f5c5e11c86ca328360991a875637528803e41dcfbba91b204a461de1109c445
+DIST syft-0.59.0-deps.tar.xz 619149756 BLAKE2B acc5118a7d64f5a785d68852984a7c6ab48eb6f745ca53a05a29995b5979c78b574794ad4daceaafa98d489d6d7a2a1e3697bda3818dce5c0dae60d15ac8cb90 SHA512 f5b565c7f19b4825fb799e47bf7971cf9337d495ab110d541a26d35dfffea4599a09911598ee867597c88bf96d289cb4ded5f73f445d68f7b0a85d7f29e5c5f3
+DIST syft-0.59.0.tar.gz 3784520 BLAKE2B fd6336d886cd9c7052b44df2f86f5ec007ffd16e8e33da9d5bd246a4c0b600a5ecd39edd5e99995aee2ee22c04f5c1fd977bd7a70f799e2638d5bd30d078cda2 SHA512 ecf0eb9b9470bceca918b37895688394d3aa6419561437908d6b9f069f12357f1713d872d139fd704817bb4ea454e5aaa0d8f6c7c8a62d046787aa57606c2cb4
diff --git a/app-containers/syft/syft-0.59.0.ebuild b/app-containers/syft/syft-0.59.0.ebuild
new file mode 100644
index 000000000000..95b08781270d
--- /dev/null
+++ b/app-containers/syft/syft-0.59.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=41bc6bb410352845f22766e27dd48ba93aa825a4
+
+DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# tests require a running docker daemon
+RESTRICT="test"
+
+src_compile() {
+ local BUILD_DATE
+ BUILD_DATE=$(date -u +%Y-%m-%dT%H:%M:%SZ)
+ ego build -o bin/syft -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/syft/internal/version.version=${PV}
+ -X github.com/anchore/syft/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/syft/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/syft/internal/version.gitDescription=v${PV}
+ " ./cmd/syft
+}
+
+src_install() {
+ dobin bin/*
+}