summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-12 17:12:06 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-12 18:03:36 +0100
commit47276b11dc0e90e19bd9a57d39e577bcb36c4bec (patch)
treed1f61b5a922ca35c0db2f2b9570f636aa2a52c32 /app-containers
parentapp-admin/keepassxc: support browser passkeys (diff)
downloadgentoo-47276b11dc0e90e19bd9a57d39e577bcb36c4bec.tar.gz
gentoo-47276b11dc0e90e19bd9a57d39e577bcb36c4bec.tar.bz2
gentoo-47276b11dc0e90e19bd9a57d39e577bcb36c4bec.zip
app-containers/distrobox: bump to 1.7.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/distrobox/Manifest1
-rw-r--r--app-containers/distrobox/distrobox-1.7.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index 52b941e75358..eba761341311 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1,2 +1,3 @@
DIST distrobox-1.6.0.1.tar.gz 6751373 BLAKE2B 9d82f33e15be8a2c17b7716ddbecf4fc533f971924c36ba8fa009dac7a87fbc26075ca98d6c58c5974fa1a02657419f26b415925d71f6577a8897a9e199950fc SHA512 cc7bd42b1c7e198eb255b6bdd90a76fa25700edc274b14379ffe3199c8a8cadc9ab27c94f43ee4a92d270b65df7b04e6c11441eb68456fe7ec3d56b2879534f2
+DIST distrobox-1.7.0.1.tar.gz 6756031 BLAKE2B 320dde2bdf005c5bd66954f212547adb6bbd6d06611272c6a1b1859eef7ad47dbbbf300baaef555e2bf9a750def117ec69418affb75514652aa0e366314fbaf2 SHA512 971a3f15216d2dfa2829a1ea085c7579c4f0bf0e57678474f83df05ae8c897db8a8cd477a429d0126cad11ac0379029b9c759944cea8649971e67f20a3e18328
DIST distrobox-1.7.0.tar.gz 6755733 BLAKE2B 27bd75046d0b221543c4870bc49305c62da03343f4a602a87a50fac9a1d5b428a040099fbea8730fe2eba0b96eb90b966bc15d5ad46d62d79157047a2048f23c SHA512 5e29a5bb4a9fca4e54df979b304c2c23af93a5326383245183fee9bc7fbf6265128e1690c653410cb3063fabc522cf38bfa041dba7b921146010f7e43630613c
diff --git a/app-containers/distrobox/distrobox-1.7.0.1.ebuild b/app-containers/distrobox/distrobox-1.7.0.1.ebuild
new file mode 100644
index 000000000000..ddd8a782dfb3
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.7.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}