summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-18 23:11:32 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-19 00:04:28 +0100
commit47814d966f2ce08db828aa8900fc08b050c19ca3 (patch)
tree72eee5627981924b8163b4470a857b142a16f23f /app-containers
parentdev-lang/dafny: disable tests requiring cargo (diff)
downloadgentoo-47814d966f2ce08db828aa8900fc08b050c19ca3.tar.gz
gentoo-47814d966f2ce08db828aa8900fc08b050c19ca3.tar.bz2
gentoo-47814d966f2ce08db828aa8900fc08b050c19ca3.zip
app-containers/earthly: bump to 0.8.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.6.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 9c5a9aa9798a..aa3bea8dd749 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -4,3 +4,5 @@ DIST earthly-0.8.4-deps.tar.xz 158470344 BLAKE2B c3ec6369f8b397abd9b76dc77461c62
DIST earthly-0.8.4.tar.gz 8041021 BLAKE2B 66057e29d4b287a220d8799efb4a1c5c43ea7641029e3af59bf8556125df28f9eafddc20d515fd20fab8c09bbb6278af4ea525f4bbe38d0e24ee031fc65c7336 SHA512 b663a10feb255329dfca30d5d70cb5c36ad5f96ed2b0cd30c46dd1b4ad087ab15b941fe6d3be3e32b1eee8199b5ee8ae50d61739c290b8967b6fcfd4126327db
DIST earthly-0.8.5-deps.tar.xz 157843872 BLAKE2B aade314abdcd8aaf18737908df1a90d71c907f286df463c9f8ce9654d5e212387b7107070225bf85f54d6e4688a741b7838b5c70d9f1a09ac15e904b83d4d2b8 SHA512 557b3477c1773c27934429677a53efbdc104230fcbd536cb73e8cd631ccf2af488731acc5555484298fc579e08b8e52031191b49ef0610595b2b67cc987232e3
DIST earthly-0.8.5.tar.gz 8051712 BLAKE2B b9310a28d79bec7a59525a541cdd51960762b0695ccf15fd33be8a9917a7e52b2251a4ebf202c4f02036b3c178b8d26fc9bc4802b9d6a73a5bfc39623c5075d7 SHA512 206dc95c2ef4b89ea7dd65b2b04f4ac7606d63891cea708f7d7dcdff8f3e9ed113b090b65c0285175412cd76fca18852bf77eeddc2e0f2782f390e5bce1f8b86
+DIST earthly-0.8.6-deps.tar.xz 157843872 BLAKE2B aade314abdcd8aaf18737908df1a90d71c907f286df463c9f8ce9654d5e212387b7107070225bf85f54d6e4688a741b7838b5c70d9f1a09ac15e904b83d4d2b8 SHA512 557b3477c1773c27934429677a53efbdc104230fcbd536cb73e8cd631ccf2af488731acc5555484298fc579e08b8e52031191b49ef0610595b2b67cc987232e3
+DIST earthly-0.8.6.tar.gz 8052646 BLAKE2B 43cb74b7ad198d6418a60dd8b3bac61c1bf67f460b73ca3627647ce71778178e69075bc5122a24cfe33c075c40e962db60845ae6d0933782432eb56087ed83f2 SHA512 4c5ae65452ff940bbeeff7ec489882c5db82597977d18ac3f187ae6a444f6b78222f16f3e0ff10250100195227b925d1a73e24c2ffce618b8675fd826302a47a
diff --git a/app-containers/earthly/earthly-0.8.6.ebuild b/app-containers/earthly/earthly-0.8.6.ebuild
new file mode 100644
index 000000000000..4396b9231a9e
--- /dev/null
+++ b/app-containers/earthly/earthly-0.8.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
+if [[ "${PV}" == 0.8.6 ]] ; then
+ COMMIT_SHA=b20c1db1cfe5816a5d2f7d416d598d5777d8f4bb
+else
+ die 'Could not detect "COMMIT_SHA", please update the ebuild.'
+fi
+
+inherit go-module
+
+DESCRIPTION="Build automation tool that executes in containers"
+HOMEPAGE="https://earthly.dev/
+ https://github.com/earthly/earthly/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+src_compile() {
+ local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
+ local go_ldflags="
+ -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
+ -X main.GitSha=${COMMIT_SHA}
+ -X main.Version=v${PV}
+ "
+ local -a go_buildargs=(
+ -tags "${go_tags}"
+ -ldflags "${go_ldflags}"
+ -o ./bin/
+ )
+ ego build "${go_buildargs[@]}" ./cmd/...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/earthly
+ newexe bin/debugger earthly-debugger
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if has_version "app-containers/podman" ; then
+ ewarn "Podman is supported but not recommended."
+ ewarn "If issues arise, then please try running earthly with docker."
+ fi
+
+ if has_version "app-containers/podman[rootless]" ; then
+ ewarn "Running podman in rootless mode is not supported because"
+ ewarn "earthly/dind and earthly/buildkit require privileged access."
+ ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
+ fi
+}