summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-16 00:31:16 +0100
committerSam James <sam@gentoo.org>2022-10-16 00:31:16 +0100
commit505868bf09a66239b2f2959a7b00c419855df02b (patch)
tree6db92417c90ed385305a996b9e9df6bbaad417f0 /app-containers
parentprofiles/default/linux: unmask www-client/firefox[clang] on LLVM profiles (diff)
downloadgentoo-505868bf09a66239b2f2959a7b00c419855df02b.tar.gz
gentoo-505868bf09a66239b2f2959a7b00c419855df02b.tar.bz2
gentoo-505868bf09a66239b2f2959a7b00c419855df02b.zip
app-containers/catatonit: use autotools.eclass
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/catatonit/catatonit-0.1.7.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-containers/catatonit/catatonit-0.1.7.ebuild b/app-containers/catatonit/catatonit-0.1.7.ebuild
index 0da65b484e47..376e881e4ac9 100644
--- a/app-containers/catatonit/catatonit-0.1.7.ebuild
+++ b/app-containers/catatonit/catatonit-0.1.7.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="A container init that is so simple it's effectively brain-dead"
HOMEPAGE="https://github.com/openSUSE/catatonit"
SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
@@ -12,11 +14,12 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 arm64 ~ppc64 ~riscv"
-PATCHES=("${DISTDIR}/${P}-automake.patch")
+PATCHES=( "${DISTDIR}/${P}-automake.patch" )
-src_configure() {
- ./autogen.sh || die
+src_prepare() {
default
+
+ eautoreconf
}
src_install() {