summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-10-07 17:07:36 -0700
committerZac Medico <zmedico@gentoo.org>2022-10-07 17:07:42 -0700
commit6e6dfb0bf56b04598106cd6635b28a0773c44bf5 (patch)
treefc1788269dc8c62f8d5e72deb695b640331333bb /app-containers
parentdev-util/ostree: add 2022.6 (diff)
downloadgentoo-6e6dfb0bf56b04598106cd6635b28a0773c44bf5.tar.gz
gentoo-6e6dfb0bf56b04598106cd6635b28a0773c44bf5.tar.bz2
gentoo-6e6dfb0bf56b04598106cd6635b28a0773c44bf5.zip
app-containers/cri-o: add 1.25.1
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/cri-o/Manifest1
-rw-r--r--app-containers/cri-o/cri-o-1.25.1.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/app-containers/cri-o/Manifest b/app-containers/cri-o/Manifest
index 5ffa4f6deed8..eea76685605a 100644
--- a/app-containers/cri-o/Manifest
+++ b/app-containers/cri-o/Manifest
@@ -1 +1,2 @@
DIST cri-o-1.25.0.tar.gz 27673668 BLAKE2B 5231f1b00781233ddf82827a580100055fefb97e768d871a845506ee28ebc122f20f6c8dff64b9dd8d991ed6ed761a72e96d607354f7e8d4182daff36ef3c253 SHA512 783c2f019ef65079dbb838e58acde5a24bda282ba8298d7b95491356e46fc208a14bcc4c65e3183001f0fb275d8ec5d7b5c795300e6424096f84fb9130721cba
+DIST cri-o-1.25.1.tar.gz 27675134 BLAKE2B 76220f63f5d9c146d6afc15b8afba2ef590faf8916ea3e7f38daeaa58dd6e039ae1a3e607c3e3a194e27f45e67a95a50ca8404f1e457aee89442fbe3505d3c67 SHA512 73b3267583b049e6aa51c1f208512d8e77bc296c34b3ad37977ee57e085b208496e11957c5cc4b55a6b4e2cc728599ce65624233d4d5a4bdc837f0dddb569323
diff --git a/app-containers/cri-o/cri-o-1.25.1.ebuild b/app-containers/cri-o/cri-o-1.25.1.ebuild
new file mode 100644
index 000000000000..65ab0adb604d
--- /dev/null
+++ b/app-containers/cri-o/cri-o-1.25.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT=afa0c576fcafc095e2827261e412fadabb016874
+
+inherit go-module
+
+DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
+HOMEPAGE="https://cri-o.io/"
+SRC_URI="https://github.com/cri-o/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="btrfs +device-mapper selinux systemd"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ app-containers/conmon
+ app-containers/runc
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ net-firewall/conntrack-tools
+ net-firewall/iptables
+ app-containers/cni-plugins
+ net-misc/socat
+ sys-apps/iproute2
+ sys-libs/libseccomp:=
+ btrfs? ( sys-fs/btrfs-progs )
+ device-mapper? ( sys-fs/lvm2:= )
+ selinux? ( sys-libs/libselinux:= )
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}
+ !<app-containers/podman-1.3.2-r1"
+
+src_prepare() {
+ default
+
+ sed -e '/^export GOPROXY=/d' \
+ -e '/^GIT_.*/d' \
+ -e '/ git diff --exit-code/d' \
+ -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
+ -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
+ -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
+ -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
+ -i Makefile || die
+
+ echo ".NOTPARALLEL: binaries docs" >> Makefile || die
+
+ sed -e 's:/usr/local/bin:/usr/bin:' \
+ -i contrib/systemd/* || die
+}
+
+src_compile() {
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die; }
+
+ [[ -f hack/libdm_installed.sh ]] || die
+ use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
+ hack/libdm_installed.sh || die; }
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ hack/selinux_tag.sh || die; }
+
+ mkdir -p bin || die
+ emake all \
+ GOBIN="${S}/bin" \
+ GO_BUILD="go build ${GOFLAGS}" \
+ GO_MD2MAN="$(which go-md2man)"
+}
+
+src_install() {
+ emake install install.config install.systemd \
+ DESTDIR="${D}" \
+ GO_MD2MAN="$(which go-md2man)" \
+ PREFIX="${D}${EPREFIX}/usr"
+ keepdir /etc/crio
+ mv "${ED}/etc/crio/crio.conf"{,.example} || die
+
+ newinitd "${FILESDIR}/crio.initd" crio
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+
+ # Suppress crio log error messages triggered if these don't exist.
+ keepdir /etc/containers/oci/hooks.d
+ keepdir /usr/share/containers/oci/hooks.d
+
+ # Suppress crio "Missing CNI default network" log message.
+ keepdir /etc/cni/net.d
+ insinto /etc/cni/net.d
+ doins contrib/cni/99-loopback.conf
+}