summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-03-15 14:22:47 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-03-15 14:24:08 -0500
commit7d58734626105af16ea82649eb35ebc7fa9bdd25 (patch)
tree67d7d773b5e42af2e830b79cee944537f00ff81d /app-containers
parentapp-containers/docker-compose: add 2.3.3-r1 (diff)
downloadgentoo-7d58734626105af16ea82649eb35ebc7fa9bdd25.tar.gz
gentoo-7d58734626105af16ea82649eb35ebc7fa9bdd25.tar.bz2
gentoo-7d58734626105af16ea82649eb35ebc7fa9bdd25.zip
app-containers/docker-compose: drop 2.3.3
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/docker-compose/docker-compose-2.3.3.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/app-containers/docker-compose/docker-compose-2.3.3.ebuild b/app-containers/docker-compose/docker-compose-2.3.3.ebuild
deleted file mode 100644
index 828aa96d4627..000000000000
--- a/app-containers/docker-compose/docker-compose-2.3.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2018-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit bash-completion-r1 go-module
-MY_PV=${PV/_/-}
-
-DESCRIPTION="Multi-container orchestration for Docker"
-HOMEPAGE="https://github.com/docker/compose"
-SRC_URI="https://github.com/docker/compose/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="2"
-KEYWORDS="~amd64"
-
-RDEPEND=">=app-containers/docker-20.10.3"
-
-S="${WORKDIR}/compose-${MY_PV}"
-
-src_prepare() {
- default
- # do not strip
- sed -i -e 's/-s -w//' builder.Makefile || die
-}
-
-src_compile() {
- emake -f builder.Makefile GIT_TAG=v${PV}
-}
-
-src_install() {
- dodir /usr/libexec/docker/cli-plugins
- exeinto /usr/libexec/docker/cli-plugins
- doexe bin/docker-compose
-dodoc README.md
-}
-
-src_test() {
- emake -f builder.Makefile test
-}
-
-pkg_postinst() {
- has_version =docker-compose-1.* || return
- elog
- elog "docker-compose 2.x is a sub command of docker"
- elog "Use 'docker compose' from the command line instead of"
- elog "'docker-compose'"
-}