summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-12 17:41:14 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-12 18:03:37 +0100
commit7df7313cd3038c9d20bf1af6d1e7ec331452d707 (patch)
tree1f5b0f6dcdf676ede174f69336ce6efc570a2dba /app-containers
parentapp-containers/earthly: drop old 0.8.0 (diff)
downloadgentoo-7df7313cd3038c9d20bf1af6d1e7ec331452d707.tar.gz
gentoo-7df7313cd3038c9d20bf1af6d1e7ec331452d707.tar.bz2
gentoo-7df7313cd3038c9d20bf1af6d1e7ec331452d707.zip
app-containers/earthly: bump to 0.8.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.5.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index dfde7814bec4..9c5a9aa9798a 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -2,3 +2,5 @@ DIST earthly-0.8.3-deps.tar.xz 158480860 BLAKE2B 4b875ef1ab7a244e2b92f13bc3dc557
DIST earthly-0.8.3.tar.gz 8034636 BLAKE2B f61133eda18d81588d35a1b4916bdc72e3a037007d4872e093be035dc25f502a8947e2610af49f8339835cc2fd607ee2bc813ad19124625f0fa55aa3e183bed8 SHA512 a2880e0b1c8d2646b70ae21557f5e05f00b31667ae10fcd124d9519b1e9a75386b7f7be3867a2ac96b3381cefa6ea1ff560844df0ae098e7ae5acc11eaa93f97
DIST earthly-0.8.4-deps.tar.xz 158470344 BLAKE2B c3ec6369f8b397abd9b76dc77461c628e14ecc5866c8b66d094c3fe3194b18330be78454b57f211a717785210da40dc3c83e7d9769c62d621ca42a9d70f7be7f SHA512 d9b0960e02cf288b933a8da954e597957b2e8dc0920e2dca208a17d41c84bc1bcff789ee1c02fa930d5d0a816cb03437b091375168e0f46f3d3cf330a643b308
DIST earthly-0.8.4.tar.gz 8041021 BLAKE2B 66057e29d4b287a220d8799efb4a1c5c43ea7641029e3af59bf8556125df28f9eafddc20d515fd20fab8c09bbb6278af4ea525f4bbe38d0e24ee031fc65c7336 SHA512 b663a10feb255329dfca30d5d70cb5c36ad5f96ed2b0cd30c46dd1b4ad087ab15b941fe6d3be3e32b1eee8199b5ee8ae50d61739c290b8967b6fcfd4126327db
+DIST earthly-0.8.5-deps.tar.xz 157843872 BLAKE2B aade314abdcd8aaf18737908df1a90d71c907f286df463c9f8ce9654d5e212387b7107070225bf85f54d6e4688a741b7838b5c70d9f1a09ac15e904b83d4d2b8 SHA512 557b3477c1773c27934429677a53efbdc104230fcbd536cb73e8cd631ccf2af488731acc5555484298fc579e08b8e52031191b49ef0610595b2b67cc987232e3
+DIST earthly-0.8.5.tar.gz 8051712 BLAKE2B b9310a28d79bec7a59525a541cdd51960762b0695ccf15fd33be8a9917a7e52b2251a4ebf202c4f02036b3c178b8d26fc9bc4802b9d6a73a5bfc39623c5075d7 SHA512 206dc95c2ef4b89ea7dd65b2b04f4ac7606d63891cea708f7d7dcdff8f3e9ed113b090b65c0285175412cd76fca18852bf77eeddc2e0f2782f390e5bce1f8b86
diff --git a/app-containers/earthly/earthly-0.8.5.ebuild b/app-containers/earthly/earthly-0.8.5.ebuild
new file mode 100644
index 000000000000..5b4f4944a279
--- /dev/null
+++ b/app-containers/earthly/earthly-0.8.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
+if [[ "${PV}" == 0.8.5 ]] ; then
+ COMMIT_SHA=a6b5b8dca64fdae64f089ac48cefa60ab39974c4
+else
+ die 'Could not detect "COMMIT_SHA", please update the ebuild.'
+fi
+
+inherit go-module
+
+DESCRIPTION="Build automation tool that executes in containers"
+HOMEPAGE="https://earthly.dev/
+ https://github.com/earthly/earthly/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+src_compile() {
+ # mkdir -p bin || die
+
+ local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
+ local go_ldflags="
+ -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
+ -X main.GitSha=${COMMIT_SHA}
+ -X main.Version=v${PV}
+ "
+ local -a go_buildargs=(
+ -tags "${go_tags}"
+ -ldflags "${go_ldflags}"
+ -o ./bin/
+ )
+ ego build "${go_buildargs[@]}" ./cmd/...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/earthly
+ newexe bin/debugger earthly-debugger
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if has_version "app-containers/podman" ; then
+ ewarn "Podman is supported but not recommended."
+ ewarn "If issues arise, then please try running earthly with docker."
+ fi
+
+ if has_version "app-containers/podman[rootless]" ; then
+ ewarn "Running podman in rootless mode is not supported because"
+ ewarn "earthly/dind and earthly/buildkit require privileged access."
+ ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
+ fi
+}