summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-03-21 11:26:12 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-03-21 11:31:12 +0200
commit88557686e5382ac1e164f61c72bb63a7a076a240 (patch)
treed86c6538bc79025054ee5c20e5e296392106d903 /app-containers
parentdev-ros/ament_cmake_export_dependencies: add missing dep (diff)
downloadgentoo-88557686e5382ac1e164f61c72bb63a7a076a240.tar.gz
gentoo-88557686e5382ac1e164f61c72bb63a7a076a240.tar.bz2
gentoo-88557686e5382ac1e164f61c72bb63a7a076a240.zip
app-containers/lxd: fix finding virtfs-proxy-helper, again
- the code has been divided amongst different files. Closes: https://bugs.gentoo.org/798924 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/lxd/lxd-4.0.9-r3.ebuild (renamed from app-containers/lxd/lxd-4.0.9-r2.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/app-containers/lxd/lxd-4.0.9-r2.ebuild b/app-containers/lxd/lxd-4.0.9-r3.ebuild
index 07794400df85..aee451bed561 100644
--- a/app-containers/lxd/lxd-4.0.9-r2.ebuild
+++ b/app-containers/lxd/lxd-4.0.9-r3.ebuild
@@ -99,6 +99,11 @@ src_prepare() {
lxd/apparmor/instance_qemu.go \
lxd/instance/drivers/driver_qemu.go || die "Failed to fix hardcoded ovmf paths."
+ # Fix hardcoded virtfs-proxy-helper file path, see bug 798924
+ sed -i \
+ -e "s:/usr/lib/qemu/virtfs-proxy-helper:/usr/libexec/virtfs-proxy-helper:g" \
+ lxd/device/device_utils_disk.go || die "Failed to fix virtfs-proxy-helper path."
+
cp "${FILESDIR}"/lxd-4.0.9-r1.service "${T}"/lxd.service || die
if use apparmor; then
sed -i \