summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-09-19 16:33:33 -0700
committerZac Medico <zmedico@gentoo.org>2022-09-19 16:33:39 -0700
commit91158050d0c0989da46655ba58e50439f329f230 (patch)
tree3d4bf21502348d8b957a2512782920f69e3bde5b /app-containers
parentsys-libs/librtas: update EAPI 7 -> 8 (diff)
downloadgentoo-91158050d0c0989da46655ba58e50439f329f230.tar.gz
gentoo-91158050d0c0989da46655ba58e50439f329f230.tar.bz2
gentoo-91158050d0c0989da46655ba58e50439f329f230.zip
app-containers/buildah: drop 1.25.1, 1.27.0
Bug: https://bugs.gentoo.org/870934 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/buildah/Manifest2
-rw-r--r--app-containers/buildah/buildah-1.25.1.ebuild51
-rw-r--r--app-containers/buildah/buildah-1.27.0.ebuild51
3 files changed, 0 insertions, 104 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index 4162262b2b9a..38ba10345072 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,3 +1 @@
-DIST buildah-1.25.1.tar.gz 14212065 BLAKE2B ec4f668654011f1b93745e1a1d575fdda0cd5f4d6f9f7f7b3106c24aa7d405951ecd645a54c2dd5a3ad2695069e66ad847bdb15f0e73a9c7efba2a7e283d4f58 SHA512 628f8095eb4488ae2be06a2a92de85dde4f3841e8ed9882132c119f27b0c93f26ba10f5dd259d63654b90539d762f6c1973d460f073c0b2450ac5d9582a6a68d
-DIST buildah-1.27.0.tar.gz 14821814 BLAKE2B e9d1ffc05024c3ae520e6436372a9eb592111c0e634d736853f7c84b225ad5e2ebf1a1d5de799a77828cc348a2b82d9fd17e720b149b55966172481155c3c6ae SHA512 7324c85b6f5169522f0cde2cbd0d55b61a2e2fc53d7f03f24ecf606fb564ee6da82cadc493520b4105501124c6c8a1e03aa67b56fb32570f303e849630286afe
DIST buildah-1.27.1.tar.gz 14825932 BLAKE2B bf290eeb4d96d255c7cdaa07af49eff44191664ac7dee255c7979656383daaa93c3673ba82ac1cbff033de769ffa08ad027f5d91c81b08a36222cb73e8a1e399 SHA512 a5e2ddf837e613554ffe8fe9c15ac9c8f9c2564c403e5544df7fb8802962581fb4e9dd4361c28c93443ede74c20c82f1631990e443c7895a3b4c3b8a659ee05a
diff --git a/app-containers/buildah/buildah-1.25.1.ebuild b/app-containers/buildah/buildah-1.25.1.ebuild
deleted file mode 100644
index d84f33be7c3f..000000000000
--- a/app-containers/buildah/buildah-1.25.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 go-module
-GIT_COMMIT=fcf94e39
-
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64"
-IUSE="selinux"
-
-RDEPEND="app-crypt/gpgme:=
- app-containers/skopeo
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-apps/shadow:=
- sys-fs/lvm2:=
- sys-libs/libseccomp:=
- selinux? ( sys-libs/libselinux:= )"
-DEPEND="${RDEPEND}"
-
-RESTRICT+=" test"
-
-src_prepare() {
- default
- [[ -f selinux_tag.sh ]] || die
- use selinux || { echo -e "#!/bin/sh\ntrue" > \
- selinux_tag.sh || die; }
- sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
-}
-
-src_compile() {
- emake GIT_COMMIT=${GIT_COMMIT} all
-}
-
-src_install() {
- dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
- doman docs/*.1
- dodoc -r docs/tutorials
- dobin bin/{${PN},imgtype}
- dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
- emake test-unit
-}
diff --git a/app-containers/buildah/buildah-1.27.0.ebuild b/app-containers/buildah/buildah-1.27.0.ebuild
deleted file mode 100644
index 76b4d6de3789..000000000000
--- a/app-containers/buildah/buildah-1.27.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 go-module
-GIT_COMMIT=db8d5921
-
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="selinux"
-
-RDEPEND="app-crypt/gpgme:=
- app-containers/skopeo
- dev-libs/libgpg-error:=
- dev-libs/libassuan:=
- sys-apps/shadow:=
- sys-fs/lvm2:=
- sys-libs/libseccomp:=
- selinux? ( sys-libs/libselinux:= )"
-DEPEND="${RDEPEND}"
-
-RESTRICT+=" test"
-
-src_prepare() {
- default
- [[ -f selinux_tag.sh ]] || die
- use selinux || { echo -e "#!/bin/sh\ntrue" > \
- selinux_tag.sh || die; }
- sed -i -e 's/make -C/$(MAKE) -C/' Makefile || die 'sed failed'
-}
-
-src_compile() {
- emake GIT_COMMIT=${GIT_COMMIT} all
-}
-
-src_install() {
- dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
- doman docs/*.1
- dodoc -r docs/tutorials
- dobin bin/{${PN},imgtype}
- dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
- emake test-unit
-}