summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-07 15:07:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-07 16:57:40 +0200
commit9a043f36c0d7b707e9ae20d46214fca4b853073c (patch)
treea7515af76e7bac10714d55bd875179eabf5d9d73 /app-containers
parentapp-emulation/libguestfs: add missing bison bdep (diff)
downloadgentoo-9a043f36c0d7b707e9ae20d46214fca4b853073c.tar.gz
gentoo-9a043f36c0d7b707e9ae20d46214fca4b853073c.tar.bz2
gentoo-9a043f36c0d7b707e9ae20d46214fca4b853073c.zip
app-containers/devcontainer: new package; add 0.52.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.52.0.ebuild46
-rw-r--r--app-containers/devcontainer/metadata.xml21
3 files changed, 68 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
new file mode 100644
index 000000000000..1fbeab3ea9cc
--- /dev/null
+++ b/app-containers/devcontainer/Manifest
@@ -0,0 +1 @@
+DIST devcontainer-0.52.0.tgz 614149 BLAKE2B 1e71d4772ec799cf8709d1d350cb8db0ea61dd2c7e96be4d35555675f9784bb1ff71ba95b6816fa9f8b6bd62c9a2b801871d51ab9fd8b564052c5939be603e2f SHA512 1790c6f2933c343b17a52d87a065e78c6e90b59249efb14c4601fc39de9a89aa6a93d100664ad3180a779c01fc181a31e59026af6bd646c214a616c61aed634c
diff --git a/app-containers/devcontainer/devcontainer-0.52.0.ebuild b/app-containers/devcontainer/devcontainer-0.52.0.ebuild
new file mode 100644
index 000000000000..399665b46cde
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.52.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}
diff --git a/app-containers/devcontainer/metadata.xml b/app-containers/devcontainer/metadata.xml
new file mode 100644
index 000000000000..07653ea3406a
--- /dev/null
+++ b/app-containers/devcontainer/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ A Development Container (or Dev Container for short) allows you to use a
+ container as a full-featured development environment. It can be used to run
+ an application, to separate tools, libraries, or runtimes needed for
+ working with a codebase, and to aid in continuous integration and testing.
+ Dev containers can be run locally or remotely, in a private or public
+ cloud, in a variety of supporting tools and editors.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/devcontainers/cli/issues/</bugs-to>
+ <remote-id type="github">devcontainers/cli</remote-id>
+ </upstream>
+</pkgmetadata>