summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-03-09 21:22:48 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-03-09 21:23:08 -0600
commita59a01a3b4c82f739f7278c457235018271ed127 (patch)
treeccb664b77689315d787e79d4a8c5c838d91707d2 /app-containers
parentapp-containers/docker-compose: Python 3.11 (diff)
downloadgentoo-a59a01a3b4c82f739f7278c457235018271ed127.tar.gz
gentoo-a59a01a3b4c82f739f7278c457235018271ed127.tar.bz2
gentoo-a59a01a3b4c82f739f7278c457235018271ed127.zip
app-containers/cosign: add 2.0.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/cosign/Manifest2
-rw-r--r--app-containers/cosign/cosign-2.0.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-containers/cosign/Manifest b/app-containers/cosign/Manifest
index 1f150f686ec4..fd2bf581c966 100644
--- a/app-containers/cosign/Manifest
+++ b/app-containers/cosign/Manifest
@@ -2,3 +2,5 @@ DIST cosign-1.13.0-deps.tar.xz 381161148 BLAKE2B 63d4423c441fbf933ac7614ba5c2b06
DIST cosign-1.13.0.tar.gz 6645872 BLAKE2B e909f87cac45dce155eb0185f3bb94dadad4aeea94b04937f288fa8d1a426028659f0277b8c4ab2c34778b7a948968fca040486257c357ef38dedfee400df792 SHA512 341928ecd7416cb4fd3023176e1f8a96f16b536810b9ea1b91d91051bfc42bc04d1fd4d03b765e39539c33ac1f94da8204f2e65f6858bc4bf7607ea78bc033c9
DIST cosign-1.13.1-deps.tar.xz 380089968 BLAKE2B 6674d7c409f1dc6a04afc11ee113a4604edf93b2b849b1d1b7273910158ac4242013e15c65bd88a1a1524d3a50a35e8292eb33819982b623ee264ad9c2b1e90a SHA512 20b74424d56a59abb0cfbe8dde41c577220ac207d144eeab3a2632c2c622b69865c80fe93545b0432156c2d45c66abf3c60f6d14f35bfad26b73e857cfe45b89
DIST cosign-1.13.1.tar.gz 6654855 BLAKE2B 85704c4bfef04d260966bc9297eb8b973627cc246ea6e293b5b7345eec3b5aef4582d1274d3e442f17f90d7a848280c31ecd9e10facbcd04b497bbc53036e93b SHA512 44fe662939fe8a4de11bd0056bad804aa706b05d56e44f6441fb85249235bdc4324cb19ecceeb39ddff28250615fb857f2727b7c1b8d5b60971b7785924d5694
+DIST cosign-2.0.0-deps.tar.xz 446730048 BLAKE2B f59c698ef5c4b908d09af10d0f254c9e03c3e109451d3e2ba2a7d5df007735651e1e28a089f07120155ee2d11648224afc2b126779ca344f0bdd8cd5f155d205 SHA512 29454a7710e18967879010f19c72ffebb75a867d495c48623fa7c61b20d770eb5868e96f0350fba275030438b309a4d1cf7a63212b208725fd5513de3693370b
+DIST cosign-2.0.0.tar.gz 6654819 BLAKE2B eee1f7f86a12173baa8d6bac2441646b61c1ce205bbd695018bcf4f068e266c245f2cbd131a40017bb8d88bc8d1960b91c49782c9cdf65e2e47ce356ffe2a92c SHA512 b64fd9bc806d72aaada007d8e0bedcd73ba42cb35fbf4c0ee589c92d5460c90e5604f0ddb6a1f12ba45ce588098803ef026a309332a78613284265e95af4354f
diff --git a/app-containers/cosign/cosign-2.0.0.ebuild b/app-containers/cosign/cosign-2.0.0.ebuild
new file mode 100644
index 000000000000..f9229084772b
--- /dev/null
+++ b/app-containers/cosign/cosign-2.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GIT_HASH=d6b9001f8e6ed745fb845849d623274c897d55f2
+inherit go-module
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+src_compile() {
+ emake \
+ GIT_HASH=${GIT_HASH} \
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean
+}
+
+src_install() {
+ dobin cosign
+ einstalldocs
+dodoc CHANGELOG.md
+}