summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-06 13:26:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-06 13:28:08 +0300
commitc294d1dca7f264a9281f6231107ddbedce2adcbc (patch)
tree249a93c4b4d48e4136da7830057b25ed351dfbca /app-containers
parentdev-python/nbformat: Remove old (diff)
downloadgentoo-c294d1dca7f264a9281f6231107ddbedce2adcbc.tar.gz
gentoo-c294d1dca7f264a9281f6231107ddbedce2adcbc.tar.bz2
gentoo-c294d1dca7f264a9281f6231107ddbedce2adcbc.zip
app-containers/conmon: add 2.1.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/conmon/Manifest1
-rw-r--r--app-containers/conmon/conmon-2.1.7.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-containers/conmon/Manifest b/app-containers/conmon/Manifest
index 5d2cef0baecb..54d026c4379c 100644
--- a/app-containers/conmon/Manifest
+++ b/app-containers/conmon/Manifest
@@ -2,3 +2,4 @@ DIST conmon-2.0.30.tar.gz 161285 BLAKE2B c4e01759d819d3dff94b9ae09caa72b6f664e49
DIST conmon-2.0.31.tar.gz 158184 BLAKE2B b14bae77a18cc352bc9583604544b4e7ffe4bd8a77e5c3185c897c11819bba227edcbd84b559d998a2b5648ca371f0e98e4d9cd15951a953cbe05a9c9ae9d434 SHA512 ff879fcd5a3b7de8ee6ff9de2a13d0afc36fdb392390278b26ee179be26ff375ddce4f5ae24e3e88b737f63202af64b49e82b2ffbfc0de8bfd14690dac523747
DIST conmon-2.1.0.tar.gz 159045 BLAKE2B a39b7620091ca17f4d91a26e040f886293688562cba1827cc09c1da1c1401ad78cbb16420c9df8a055ab5ca3eb2933aec6ac1b9fbb1eea10f33b1b0d76c5dd54 SHA512 0f27a1b048c2dcafb40cd67f80c2a5d7e92f5beb849174233dc10e2db42b4ea8b89f27c901d3f38cf1d412ed875c5521e07140038e859fb54bcc554cb9197e74
DIST conmon-2.1.6.tar.gz 157838 BLAKE2B 319a170ab048c14f3be998391da403799171c5d0e342ac4214a6456398ab872cb6a77cb4d67dbb97a0bc47008c6fa657ba2a166eea4c56ee65db545b08e032bd SHA512 0b5d7f33745766f4f1646e79554e16e1d6c977fd08c5a86c72068aec9f28110b5981c38972134741281c8470c295b6195843f3dbb78e1e9da34b8d577ea41d65
+DIST conmon-2.1.7.tar.gz 158201 BLAKE2B 2f159177cfa78ecafef0217d21c9c56942c5498022d3777368d8caf81c2503aafabf002c0f9ec0537936eca34c156ed9bdd037b5543eca1edd5489d9bc1ac215 SHA512 95d394b399a19a62b894cdd03937ab79b81051eea1db461b1bf957ddd7626d6ca4aa108b8319ed8c08adbdf99fd960c5ba29146e8b0673b5c920708912a72973
diff --git a/app-containers/conmon/conmon-2.1.7.ebuild b/app-containers/conmon/conmon-2.1.7.ebuild
new file mode 100644
index 000000000000..e595091b3668
--- /dev/null
+++ b/app-containers/conmon/conmon-2.1.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+SRC_URI="https://github.com/containers/conmon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+IUSE="systemd"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:=
+ sys-libs/libseccomp
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}
+ dev-go/go-md2man"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| $(PKG_CONFIG) --exists libsystemd-journal | false |' \
+ -e 's| $(PKG_CONFIG) --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+ sed -e 's|make -C tools|$(MAKE) -C tools|' -i Makefile || die
+ sed -e 's|^GOMD2MAN = .*|GOMD2MAN = go-md2man|' -i docs/Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake GIT_COMMIT="v${PV}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ install
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/conmon || die
+ dodoc README.md
+}