summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-07-16 14:38:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-07-16 14:38:41 -0500
commitc691680319ac2f00f203533c3dca0b21ecf77f80 (patch)
tree6eadb1f3387fd1b8a29913909e65c3507903693e /app-containers
parentapp-containers/grype: add 0.42.0 (diff)
downloadgentoo-c691680319ac2f00f203533c3dca0b21ecf77f80.tar.gz
gentoo-c691680319ac2f00f203533c3dca0b21ecf77f80.tar.bz2
gentoo-c691680319ac2f00f203533c3dca0b21ecf77f80.zip
app-containers/syft: add 0.51.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/syft/Manifest2
-rw-r--r--app-containers/syft/syft-0.51.0.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
index a44477d767c7..36d994cb4794 100644
--- a/app-containers/syft/Manifest
+++ b/app-containers/syft/Manifest
@@ -2,3 +2,5 @@ DIST syft-0.45.1-deps.tar.xz 619145524 BLAKE2B c39ce29edb6820ff620f2d25b564084b2
DIST syft-0.45.1.tar.gz 3826388 BLAKE2B 9600f44d4d0390c2cda422ccec04ab8f27165ed00cb031dfc441e21a156f5abfb1e63ed26bbc5795b074d2b8f578486624f8a88c87248a5c70a02268d728bbf2 SHA512 938af62b5c9d724d206db98174892bede409f4bfb9199d636cf3cedfa605cc79f2e4d9c2b49868e4f9ac1ab64d05b42849d15c9f28bf4c7a2b531449f346ef85
DIST syft-0.47.0-deps.tar.xz 631564724 BLAKE2B 4eb6dedb2173d5dda214b4bb450fa6e85c1946ee8388064d8a7beb3f9fd4589ede95069b1ade378e04320326f012af155375b67c9502026454d4b97cb5183be6 SHA512 e2d0ff159be544a525a9628ad698499735073323e6b91531c636bc6ca15acfd3ee0625b87abc76dd74eaceffd912f98845c0f4126a364672414fac29cd7b3af7
DIST syft-0.47.0.tar.gz 3846983 BLAKE2B 2833b360de24fc8c5ca2073bc776e2d33f8c78d7d25f8a622e8420b528e4c517c1298c1479d916a2a90b97cb44f1b5e407a9dc2a09016e7ccf6238d0050eb696 SHA512 997d6e7139be8c686ee38df9fe42fa50dac17e522c51db005628cf3fd6a97ef9f9758e86fe6c6e58a199d852bc4eeac88b3932c5f3847547382987cd02260551
+DIST syft-0.51.0-deps.tar.xz 632084588 BLAKE2B f9b3e4e41521c25b6e338f2b8f3bba0be08e7608d95de7dba6f5f104e22b8de8a4b419e574e19634099a3bbc55556f83949c68abd5ae52d14b5e97cb9306bf22 SHA512 819236c275762cc42c60339ee2d6886f0998f34609ab0bbef3150b23fbcf3cecaea63d92f6e2e161bf3ec30edae00ef467755900fd1c98389db2f9cd8113fbf4
+DIST syft-0.51.0.tar.gz 3727474 BLAKE2B ae9f54f421faa530aabbbadd985071f603ccaa32c6cd5f0dd400ea9163a218e8ddd5e7035042a7eda6cd06910ce96ae0f42b7422c932992fad812431a42ac059 SHA512 fb844a76d3f3f303e781cea40ac6fb573927f6465a39da10fe9cffeb08ce7b1e8b8ed4acb219206e53159f802eaa12dce73ce5bc3b868f6f4270a30498b6b767
diff --git a/app-containers/syft/syft-0.51.0.ebuild b/app-containers/syft/syft-0.51.0.ebuild
new file mode 100644
index 000000000000..2c42d972b97c
--- /dev/null
+++ b/app-containers/syft/syft-0.51.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o bin/syft ./cmd/syft
+}
+
+src_install() {
+dobin bin/*
+}