summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-10-04 15:48:10 +0100
committerMarek Szuba <marecki@gentoo.org>2022-10-04 16:02:34 +0100
commitd6156693866bb3cd6799e97e61fbc5f7ba998d06 (patch)
treecd508ab37ff7494a726bee07a1e72368bba30a40 /app-containers
parentsys-fs/squashfuse: keyword 0.1.103 for ~riscv (diff)
downloadgentoo-d6156693866bb3cd6799e97e61fbc5f7ba998d06.tar.gz
gentoo-d6156693866bb3cd6799e97e61fbc5f7ba998d06.tar.bz2
gentoo-d6156693866bb3cd6799e97e61fbc5f7ba998d06.zip
app-containers/apptainer: add 1.1.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/apptainer/Manifest1
-rw-r--r--app-containers/apptainer/apptainer-1.1.0.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-containers/apptainer/Manifest b/app-containers/apptainer/Manifest
index fdf12d711a48..f9b1996594e9 100644
--- a/app-containers/apptainer/Manifest
+++ b/app-containers/apptainer/Manifest
@@ -1 +1,2 @@
DIST apptainer-1.0.3.tar.gz 11972174 BLAKE2B 7fb0602184d9d78ef0de224ec888a01e046d3d44cd79a3233bbb8eab276d9ee360810356a25f4ef05612e337b5a905334f528d5aa5bfa489d9910538719afd2c SHA512 93ebe5abce32f35d56fe7d0f818703961cb7f7115965bad387fc895a275d45b569efeecf57ab5778457732233caa57651cd011a3bcac5ed5aaf2dd665082d959
+DIST apptainer-1.1.0.tar.gz 12761996 BLAKE2B 60b145c68a4c2f7587cbefb94e28337e3f3c9cee51b0f07a024a313605e5cc087bcc0d2775bf83691aa5f5c6d5b84870697acd2e5b09e685f9e44ec766afde2b SHA512 ea7db1d4b9bc5b87542a044abc82f04759b09a676fb429bfb3f33c9a4eb01808f1c2c81e450e99a273b5c61a7df723680352ebc6a1124a6efc060bb85defe20f
diff --git a/app-containers/apptainer/apptainer-1.1.0.ebuild b/app-containers/apptainer/apptainer-1.1.0.ebuild
new file mode 100644
index 000000000000..3134281dcb06
--- /dev/null
+++ b/app-containers/apptainer/apptainer-1.1.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="The container system for secure high-performance computing"
+HOMEPAGE="https://apptainer.org/"
+SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network suid systemd"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+DEPEND="app-crypt/gpgme
+ >=dev-lang/go-1.17.6
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ sys-fs/squashfs-tools
+ sys-libs/libseccomp
+ !suid? (
+ sys-fs/e2fsprogs[fuse]
+ sys-fs/squashfuse
+ )"
+RDEPEND="${DEPEND}
+ !sys-cluster/singularity"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~SQUASHFS"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-trim_upstream_cflags.patch
+)
+
+DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --runstatedir="${EPREFIX}"/run \
+ --localstatedir="${EPREFIX}"/var \
+ $(usex network "" "--without-network") \
+ $(use_with suid)
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C builddir install
+ keepdir /var/${PN}/mnt/session
+
+ if use systemd; then
+ sed -i -e '/systemd cgroups/ s/no/yes/' "${ED}"/etc/${PN}/${PN}.conf || die "Failed to enable systemd use in configuration"
+ else
+ sed -i -e '/systemd cgroups/ s/yes/no/' "${ED}"/etc/${PN}/${PN}.conf || die "Failed to disable systemd use in configuration"
+ fi
+
+ einstalldocs
+ if use examples; then
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ if ! use suid; then
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.1.0; then
+ ewarn "Since version 1.1.0 ${PN} no longer installs setuid-root components by default, relying on unprivileged user namespaces instead. For details, see https://apptainer.org/docs/admin/main/user_namespace.html"
+ ewarn "Make sure user namespaces (possibly except network ones for improved security) are enabled on your system, or re-enable installation of setuid root components by passing USE=suid to ${CATEGORY}/${PN}"
+ break
+ fi
+ done
+ fi
+}