summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-06-03 00:09:10 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-06-03 00:09:10 +0200
commit573170f20efce70334eb0dd0a36de75702b507d6 (patch)
tree08c4a0d4ee26b3993f2d5007ca9177a342b2b4d1 /app-crypt/acme-sh
parentdev-lua/mpack: fix double prefix (diff)
downloadgentoo-573170f20efce70334eb0dd0a36de75702b507d6.tar.gz
gentoo-573170f20efce70334eb0dd0a36de75702b507d6.tar.bz2
gentoo-573170f20efce70334eb0dd0a36de75702b507d6.zip
app-crypt/acme-sh: bump to version 2.9.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh')
-rw-r--r--app-crypt/acme-sh/Manifest1
-rw-r--r--app-crypt/acme-sh/acme-sh-2.9.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index 29b635c8b299..9211d7b33cde 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1 +1,2 @@
DIST acme.sh-2.8.9.tar.gz 233430 BLAKE2B fa2c16007bc07dd597443103ebf3afa4986e3885b2b3e0a545cf79408741709171ee67fe019e2abf7891d08cef9d2560a438695dd32c72eb729ea2bea2900221 SHA512 94f771fcbc5b12a2a9992659884d16b543d70db52bccf20eddad931b4a5c233c0fd7362ce525e0cbebfdbd841824b815f5b419572f97b549fea7f2663c92c0a8
+DIST acme.sh-2.9.0.tar.gz 232001 BLAKE2B bab24bae37098b41e2b5acc5c4fd7106274b9bcc309d605722d4e412c4be1c72b516d59029c246472dfa7adc9575e29bbf2cf7e084177bedaf86516f311c4847 SHA512 bfe19e322b18830406f372a920873b6a4ced0dd2358bdf2f59a97d6b6e163276dd362b51d3b6eef5eb941fd6245d77768bb7b9ed8cfc5182ed171a4263bfb1a1
diff --git a/app-crypt/acme-sh/acme-sh-2.9.0.ebuild b/app-crypt/acme-sh/acme-sh-2.9.0.ebuild
new file mode 100644
index 000000000000..a6b09a058aa2
--- /dev/null
+++ b/app-crypt/acme-sh/acme-sh-2.9.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+inherit optfeature
+
+DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
+HOMEPAGE="https://github.com/acmesh-official/acme.sh"
+SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:0
+ net-misc/curl
+ net-misc/socat
+"
+
+src_install() {
+ newdoc deploy/README.md README-deploy.md
+ newdoc dnsapi/README.md README-dnsapi.md
+ rm {deploy,dnsapi}/README.md || die
+ einstalldocs
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+
+ insinto /usr/share/acme.sh
+ doins -r deploy dnsapi notify
+
+ keepdir /etc/acme-sh
+ doenvd "${FILESDIR}"/99acme-sh
+
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}"/acme.sh
+
+ dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
+}
+
+pkg_postinst() {
+ optfeature_header "For webserver mode, install a supported web server:"
+ optfeature "using apache2 webserver mode" www-servers/apache
+ optfeature "using nginx webserver mode" www-servers/nginx
+}