summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-09-23 13:06:31 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-09-23 13:09:54 +0200
commita85fd8486d53508a9d6550e6ecde4317486919ef (patch)
tree17158d4228394266004274eaeca15e01b2cfbefb /app-crypt/acme-sh
parentdev-lang/yasm: Use HTTPS (diff)
downloadgentoo-a85fd8486d53508a9d6550e6ecde4317486919ef.tar.gz
gentoo-a85fd8486d53508a9d6550e6ecde4317486919ef.tar.bz2
gentoo-a85fd8486d53508a9d6550e6ecde4317486919ef.zip
app-crypt/acme-sh: bump to version 2.8.7
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh')
-rw-r--r--app-crypt/acme-sh/Manifest1
-rw-r--r--app-crypt/acme-sh/acme-sh-2.8.7.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index caf9c58a1e18..77afd3e72a25 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1,2 +1,3 @@
DIST acme.sh-2.8.3.tar.gz 163573 BLAKE2B 7436932d79e732b8c419a588f4677ec0338c63d0dfc227e7410b151731e2fc4c028df81f459f7ad140dab857ebdebddab3173095e3efcfad0a971ff6762c8608 SHA512 15e147d0f07af91eab7274df50e274ae41a411c30ee7f6ebc8bcbcb601b66094fc1d8126bfb816caa27dbeb5222da20a25d1c79227bc70ddb6b5d0ce0dcb389e
DIST acme.sh-2.8.5.tar.gz 176854 BLAKE2B 74eb9bbf4b99984ba77725c6751b713d6971503d1a8542472e75192afc9139705607f629e673af75b6ec7dab68b1a9ad2fd4676cda26871daf475487e28e0848 SHA512 db355d8c60c61b632c62dda376e71c438035d3eaf5630a6dc3ca241f6d988216f046e1588ccfe3da955aacb7897cefac5a8c7b6868f12af8f422182c52ed7b72
+DIST acme.sh-2.8.7.tar.gz 206475 BLAKE2B ac1d51efac6301210ffd8b6e5ff6ed490cbf80e7dd154ec7a2ad0b6a2dd08ac73a325e332192214c964a873ba7c6f01a43a2157963d7edec9e0ec45b47e5b689 SHA512 45599f50a4a45b6fdea58d7a5759e4eb5f8e33acc53d60b264c15662e6bdc1e353af610845056fc67b127242c4ad15eaaf60a2113f2cb0245d4e4861dac6e1c3
diff --git a/app-crypt/acme-sh/acme-sh-2.8.7.ebuild b/app-crypt/acme-sh/acme-sh-2.8.7.ebuild
new file mode 100644
index 000000000000..af53d7dec342
--- /dev/null
+++ b/app-crypt/acme-sh/acme-sh-2.8.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An ACME Shell script"
+HOMEPAGE="https://github.com/Neilpang/acme.sh"
+SRC_URI="https://github.com/Neilpang/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ net-misc/curl
+ || ( dev-libs/libressl dev-libs/openssl:0 )
+ || ( net-analyzer/netcat net-analyzer/openbsd-netcat )
+ || ( net-misc/socat www-servers/apache:2 www-servers/nginx )
+ virtual/cron
+"
+
+src_install() {
+ einstalldocs
+ newdoc dnsapi/README.md README-dnsapi.md
+ newdoc deploy/README.md README-deploy.md
+
+ keepdir /etc/acme-sh
+ doenvd "${FILESDIR}"/99acme-sh
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}"/acme.sh
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+ insinto /usr/share/acme.sh/dnsapi
+ doins -r dnsapi/*.sh
+ insinto /usr/share/acme.sh/deploy
+ doins -r deploy/*.sh
+ insinto /usr/share/acme.sh/notify
+ doins -r notify/*.sh
+
+ dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
+}