summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-05-04 15:54:24 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-05-04 15:54:24 +0200
commitb320a5e4b179ac73361ebd995cb1e7e487ddd26a (patch)
tree2ae96c90bb55d08a976b762d95ac1384ca4d8f73 /app-crypt/acme-sh
parentmedia-fonts/fontawesome: version bump to 5.15.3 (diff)
downloadgentoo-b320a5e4b179ac73361ebd995cb1e7e487ddd26a.tar.gz
gentoo-b320a5e4b179ac73361ebd995cb1e7e487ddd26a.tar.bz2
gentoo-b320a5e4b179ac73361ebd995cb1e7e487ddd26a.zip
app-crypt/acme-sh: bump to version 2.8.9
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh')
-rw-r--r--app-crypt/acme-sh/Manifest1
-rw-r--r--app-crypt/acme-sh/acme-sh-2.8.9.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index 7149e334d2a6..b5dbb442f11f 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1 +1,2 @@
DIST acme.sh-2.8.8.tar.gz 218582 BLAKE2B bcd2fbc0ff984d7bbcf4e0ee4c1f08f868ebc4b31a5d217587cdeb5810b8991698de52dd082219194c762ef245324e981eb2a044b213e2713c0d12370be1c19b SHA512 cf601965cd5542dbd11668330d0a4e428e89ccc3af92d4d04ea3936c8a31979a5c00aa8e18a31fde07812242dddcebbfdbc06f1c29260b917dfa19f88d12fd72
+DIST acme.sh-2.8.9.tar.gz 233430 BLAKE2B fa2c16007bc07dd597443103ebf3afa4986e3885b2b3e0a545cf79408741709171ee67fe019e2abf7891d08cef9d2560a438695dd32c72eb729ea2bea2900221 SHA512 94f771fcbc5b12a2a9992659884d16b543d70db52bccf20eddad931b4a5c233c0fd7362ce525e0cbebfdbd841824b815f5b419572f97b549fea7f2663c92c0a8
diff --git a/app-crypt/acme-sh/acme-sh-2.8.9.ebuild b/app-crypt/acme-sh/acme-sh-2.8.9.ebuild
new file mode 100644
index 000000000000..a6b09a058aa2
--- /dev/null
+++ b/app-crypt/acme-sh/acme-sh-2.8.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+inherit optfeature
+
+DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
+HOMEPAGE="https://github.com/acmesh-official/acme.sh"
+SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:0
+ net-misc/curl
+ net-misc/socat
+"
+
+src_install() {
+ newdoc deploy/README.md README-deploy.md
+ newdoc dnsapi/README.md README-dnsapi.md
+ rm {deploy,dnsapi}/README.md || die
+ einstalldocs
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+
+ insinto /usr/share/acme.sh
+ doins -r deploy dnsapi notify
+
+ keepdir /etc/acme-sh
+ doenvd "${FILESDIR}"/99acme-sh
+
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}"/acme.sh
+
+ dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
+}
+
+pkg_postinst() {
+ optfeature_header "For webserver mode, install a supported web server:"
+ optfeature "using apache2 webserver mode" www-servers/apache
+ optfeature "using nginx webserver mode" www-servers/nginx
+}