summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-02-07 18:29:39 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-02-07 18:29:39 -0600
commit38012b889f3a5016a75a01d4cbd89ba76daef058 (patch)
treeed815d381c109eda7a0083d7febd32532c5226e3 /app-crypt/acme/acme-0.31.0.ebuild
parentsys-cluster/cinder: 13.0.3 bump (diff)
downloadgentoo-38012b889f3a5016a75a01d4cbd89ba76daef058.tar.gz
gentoo-38012b889f3a5016a75a01d4cbd89ba76daef058.tar.bz2
gentoo-38012b889f3a5016a75a01d4cbd89ba76daef058.zip
app-crypt/acme: 0.30.1 stable amd64/x86; 0.31.0 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/acme/acme-0.31.0.ebuild')
-rw-r--r--app-crypt/acme/acme-0.31.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/acme/acme-0.31.0.ebuild b/app-crypt/acme/acme-0.31.0.ebuild
new file mode 100644
index 000000000000..cc94bdaee734
--- /dev/null
+++ b/app-crypt/acme/acme-0.31.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/cryptography-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.0.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ nosetests -w ${PN} || die
+}