summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-12-02 20:53:31 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-12-02 21:24:14 -0600
commit543497fb933ef213d2e7fe709405dab59275a2fc (patch)
tree4eb992b6ef4ef0ff625777ba99b80ee9ae415a69 /app-crypt/acme
parentsec-policy: Stabilize SELinux policy 2.20200818-r2 (diff)
downloadgentoo-543497fb933ef213d2e7fe709405dab59275a2fc.tar.gz
gentoo-543497fb933ef213d2e7fe709405dab59275a2fc.tar.bz2
gentoo-543497fb933ef213d2e7fe709405dab59275a2fc.zip
app-crypt/acme: 1.10.0 bump
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-1.10.0.ebuild69
-rw-r--r--app-crypt/acme/acme-1.9.0.ebuild2
3 files changed, 71 insertions, 1 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 7c86ae3bafc1..d66d65257c2d 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1 +1,2 @@
+DIST certbot-1.10.0.tar.gz 1432396 BLAKE2B eae502acdac712ac148a4a349b500db61a0c14fda0ae4dc57077222d33f967595c4434d0b197649c6d2614018bafaab2c7f94c1571162a200943732cc3c0109c SHA512 af31bfa1f3d6bc189d1b55ac91aab5b7fb35579170c253f0c0e98c5f63be9ad27f3ff73cb03a4f59765874c01e78ae1423f977426e081161ae5f845ebfb0d23a
DIST certbot-1.9.0.tar.gz 1425703 BLAKE2B 9bf78824649870b3e1fc3175aae551cbfaa675a8930a89f35ba2330647d86798e4fc43011c617be2d278ab20c43dd05b02e8e61956dd7f9d10d444181874346e SHA512 098d8c077f5760c1f40f7d673820488ad7643c8b9c12561a58921cd95f60ae76515cefc19f822747f3385a68eba6f49fe5484b20142994ef67a26b0b16293ce8
diff --git a/app-crypt/acme/acme-1.10.0.ebuild b/app-crypt/acme/acme-1.10.0.ebuild
new file mode 100644
index 000000000000..9c58fbb71ad7
--- /dev/null
+++ b/app-crypt/acme/acme-1.10.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+ distutils-r1_src_compile
+ if use doc ; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests -w ${PN} || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/app-crypt/acme/acme-1.9.0.ebuild b/app-crypt/acme/acme-1.9.0.ebuild
index da638d5ba966..e7b061126cc4 100644
--- a/app-crypt/acme/acme-1.9.0.ebuild
+++ b/app-crypt/acme/acme-1.9.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
+PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then