summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-12-23 11:30:36 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2015-12-23 13:15:38 +0200
commit9daa04e38d22410e302bea82953c61b33a79dfc7 (patch)
tree6a6b7f21da20e6f1383aa67bd970263ad20a612b /app-crypt/aespipe/aespipe-2.4d.ebuild
parentdev-cpp/gtkmm-utils: Fix building with latest glibmm/libsigc++ (diff)
downloadgentoo-9daa04e38d22410e302bea82953c61b33a79dfc7.tar.gz
gentoo-9daa04e38d22410e302bea82953c61b33a79dfc7.tar.bz2
gentoo-9daa04e38d22410e302bea82953c61b33a79dfc7.zip
app-crypt/aespipe: version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-crypt/aespipe/aespipe-2.4d.ebuild')
-rw-r--r--app-crypt/aespipe/aespipe-2.4d.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-crypt/aespipe/aespipe-2.4d.ebuild b/app-crypt/aespipe/aespipe-2.4d.ebuild
new file mode 100644
index 000000000000..62ceb09ad12c
--- /dev/null
+++ b/app-crypt/aespipe/aespipe-2.4d.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="Encrypts data from stdin to stdout"
+HOMEPAGE="http://loop-aes.sourceforge.net"
+SRC_URI="http://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_padlock static"
+DEPEND=""
+RDEPEND="app-arch/sharutils
+ app-crypt/gnupg"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ $(use_enable asm) \
+ $(use_enable cpu_flags_x86_aes intelaes) \
+ $(use_enable cpu_flags_x86_padlock padlock)
+}