summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-09-15 08:45:19 +0300
committerSam James <sam@gentoo.org>2023-09-24 23:07:29 +0100
commitcb6d3c717a87fabae248dab4a06416e20a5a7d26 (patch)
treef525323a1b2bbd0e0b1dd793d1929c17738d77c4 /app-crypt/asekey/files
parentapp-crypt/asekey: remove HOMEPAGE, mirror distfile in gentoo namespace (diff)
downloadgentoo-cb6d3c717a87fabae248dab4a06416e20a5a7d26.tar.gz
gentoo-cb6d3c717a87fabae248dab4a06416e20a5a7d26.tar.bz2
gentoo-cb6d3c717a87fabae248dab4a06416e20a5a7d26.zip
app-crypt/asekey: update EAPI 7 -> 8
Closes: https://bugs.gentoo.org/714222 Closes: https://bugs.gentoo.org/745291 Closes: https://bugs.gentoo.org/854237 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/32791 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/asekey/files')
-rw-r--r--app-crypt/asekey/files/asekey-3.7-dont-call-toolchain-cc-directly.patch13
-rw-r--r--app-crypt/asekey/files/asekey-3.7-musl-ushort.patch14
2 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/asekey/files/asekey-3.7-dont-call-toolchain-cc-directly.patch b/app-crypt/asekey/files/asekey-3.7-dont-call-toolchain-cc-directly.patch
new file mode 100644
index 000000000000..ba51ff4dea9f
--- /dev/null
+++ b/app-crypt/asekey/files/asekey-3.7-dont-call-toolchain-cc-directly.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/745291
+
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@
+ DRIVER_DIR=${DESTDIR}/${USBDROPDIR}/ifd-ASEKey.bundle
+ UDEV_DIR=${DESTDIR}/${UDEVDIR}
+
+-CC=${BUILD}-gcc
++CC?=gcc
+
+ SOURCES=usb.c atr.c DriverIO.c CommandTypes.c ReaderCommands.c T1Protocol.c MemoryCards.c InitCardParams.c ifdhandler.c
+
diff --git a/app-crypt/asekey/files/asekey-3.7-musl-ushort.patch b/app-crypt/asekey/files/asekey-3.7-musl-ushort.patch
new file mode 100644
index 000000000000..5893527eff8a
--- /dev/null
+++ b/app-crypt/asekey/files/asekey-3.7-musl-ushort.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/714222
+
+Hack instead of fix because upstream is dead and the typedef is used extensively.
+
+--- a/Ase.h
++++ b/Ase.h
+@@ -24,6 +24,7 @@
+ #include "T1Protocol.h"
+ #include "MemoryCards.h"
+
++typedef unsigned short ushort;
+
+ //#define ASE_DEBUG
+