summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/bcrypt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/bcrypt')
-rw-r--r--app-crypt/bcrypt/Manifest1
-rw-r--r--app-crypt/bcrypt/bcrypt-1.1.ebuild33
-rw-r--r--app-crypt/bcrypt/files/bcrypt-1.1-Makefile.patch19
-rw-r--r--app-crypt/bcrypt/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/bcrypt/Manifest b/app-crypt/bcrypt/Manifest
new file mode 100644
index 000000000000..2e9b9ad082e3
--- /dev/null
+++ b/app-crypt/bcrypt/Manifest
@@ -0,0 +1 @@
+DIST bcrypt-1.1.tar.gz 36781 SHA256 b9c1a7c0996a305465135b90123b0c63adbb5fa7c47a24b3f347deb2696d417d SHA512 4cc939e997b125b48a66c20469d9743ec227dbee080d89b1ab2515a3c41749c6e8fb6d2d4276cd23eaf6bed0614989431f1f87c23220a94ad595024f8985d68b WHIRLPOOL 9ff061cb2aba0e7cca7ba131ee2789b4136b9251a6704f3713eb897a549a6619e38b9efcced9647d17aa4eb9baea80cb477af53cbfdc9e21cc96079127412a94
diff --git a/app-crypt/bcrypt/bcrypt-1.1.ebuild b/app-crypt/bcrypt/bcrypt-1.1.ebuild
new file mode 100644
index 000000000000..07266aa2a6a8
--- /dev/null
+++ b/app-crypt/bcrypt/bcrypt-1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A file encryption utility using Paul Kocher's implementation of the blowfish algorithm"
+HOMEPAGE="http://bcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bcrypt/${P}.tar.gz"
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="alpha amd64 ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin bcrypt || die
+ dodoc README || die
+ doman bcrypt.1 || die
+}
diff --git a/app-crypt/bcrypt/files/bcrypt-1.1-Makefile.patch b/app-crypt/bcrypt/files/bcrypt-1.1-Makefile.patch
new file mode 100644
index 000000000000..1b210392427e
--- /dev/null
+++ b/app-crypt/bcrypt/files/bcrypt-1.1-Makefile.patch
@@ -0,0 +1,19 @@
+--- Makefile.old 2006-11-23 13:58:19.000000000 +0100
++++ Makefile 2006-11-23 13:59:52.000000000 +0100
+@@ -1,13 +1,12 @@
+ DEFAULTS = Makefile includes.h blowfish.h functions.h config.h
+-CC = gcc
+-CFLAGS = -O2 -Wall
++CFLAGS += -Wall
+ COMPILE = ${CC} ${CFLAGS}
+ OBJS = main.o blowfish.o rwfile.o keys.o wrapbf.o endian.o wrapzl.o
+-LDFLAGS = -L/usr/local/lib -lz
++LIBS = -lz
+ PREFIX = /usr/local
+
+ bcrypt: ${OBJS} Makefile
+- ${COMPILE} -o bcrypt ${OBJS} ${LDFLAGS}
++ ${COMPILE} ${LDFLAGS} -o bcrypt ${OBJS} ${LIBS}
+
+ install: bcrypt Makefile
+ mkdir -p ${PREFIX}/bin;\
diff --git a/app-crypt/bcrypt/metadata.xml b/app-crypt/bcrypt/metadata.xml
new file mode 100644
index 000000000000..eb17ed1ab0b2
--- /dev/null
+++ b/app-crypt/bcrypt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <upstream>
+ <remote-id type="sourceforge">bcrypt</remote-id>
+ </upstream>
+</pkgmetadata>