summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-04-21 12:04:13 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-04-21 12:04:39 +0300
commit9f3a21fdf3df0e933d9184816c359f1007ba0610 (patch)
treee1798bfab2a10fc8de22301dc5de5cf2cad8e515 /app-crypt/ccid
parentapp-crypt/ccid: site moved (diff)
downloadgentoo-9f3a21fdf3df0e933d9184816c359f1007ba0610.tar.gz
gentoo-9f3a21fdf3df0e933d9184816c359f1007ba0610.tar.bz2
gentoo-9f3a21fdf3df0e933d9184816c359f1007ba0610.zip
app-crypt/ccid: vesion bump
Closes: https://bugs.gentoo.org/653632 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-crypt/ccid')
-rw-r--r--app-crypt/ccid/Manifest1
-rw-r--r--app-crypt/ccid/ccid-1.4.29.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/ccid/Manifest b/app-crypt/ccid/Manifest
index 34d12fa9c6a5..9a5d1a8edc9d 100644
--- a/app-crypt/ccid/Manifest
+++ b/app-crypt/ccid/Manifest
@@ -1,2 +1,3 @@
DIST ccid-1.4.26.tar.bz2 628038 BLAKE2B ba0cc8aa92a7b960d12e0ebfba79910c84eff11815495bda76287bacb7638093270eb2b5bc502c67b1a789a6bef19deac338312b044d74f6f7348adebd2a621e SHA512 4a2e5e9412f2aa4870e14114e54da96fd8b3418ea6d3a236b83e19d6349adb20a94ef7f48628c108f8459f008c10b0606bbf4d797ae4be9183e1acde032c618c
DIST ccid-1.4.27.tar.bz2 632817 BLAKE2B a18de0594c9535c4564bc27886fc69a0edc54343941d77b9558f331a932d12d2b58303ae3994337e380f16648f7bb2a8aa90c00aae4c7cffe242e000003c5dcd SHA512 14fb5d9878ed36de912d860d8537758170781f225957a99d5fed447dcfba0cba3133f78d2cc4bc7db60d3527399f70e4a7d1d1f8348fb50d1bcfc75820a23522
+DIST ccid-1.4.29.tar.bz2 635761 BLAKE2B ff14bc6e181a6d44b8ef463a2255d0362842f6e1e7c79e0a01caaba0a88892f7b0f2bd9d2dadae7be8b0655d2502e5471cff29e582928d62235fa070f2eb1ba8 SHA512 9ff37acad086e959f660069b245fe06ecada140623025a19dfbff55edec71e1e72bce09ac4fc506ad985dd0831dafc6b12f5a5b109b38bf9ba7583856eb19418
diff --git a/app-crypt/ccid/ccid-1.4.29.ebuild b/app-crypt/ccid/ccid-1.4.29.ebuild
new file mode 100644
index 000000000000..96196218e361
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.29.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs udev
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="https://ccid.apdu.fr/"
+SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="twinserial kobil-midentity +usb"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.8.3
+ usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( virtual/pkgconfig )"
+
+DOCS=( README AUTHORS )
+
+src_configure() {
+ econf \
+ LEX=: \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_compile() {
+ default
+ use kobil-midentity && emake -C contrib/Kobil_mIDentity_switch
+}
+
+src_install() {
+ default
+
+ if use kobil-midentity; then
+ dosbin contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
+ doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
+ fi
+
+ if use kernel_linux; then
+ # note: for eudev support, rules probably will always need to be
+ # installed to /usr
+
+ # ccid >=1.4.11 version changed the rules drastically in a minor
+ # release to no longer use the pcscd group. Using the old ones in
+ # the mean time.
+ udev_newrules "${FILESDIR}"/92_pcscd_ccid-2.rules 92-pcsc-ccid.rules
+
+ # disable Kobil_mIDentity_switch udev rule with USE=-kobil-midentity
+ if ! use kobil-midentity; then
+ sed \
+ -e '/Kobil_mIDentity_switch/s/^/#/' \
+ -i "${D}/$(get_udevdir)"/rules.d/92-pcsc-ccid.rules || die
+ fi
+
+ fi
+}