summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-09 16:46:37 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-09 16:47:13 -0500
commitda32514f0015c3f8046ffa89463c46d3e9527ac8 (patch)
treee02b2b0287ab9814302f67f262263ad3a8ed0770 /app-crypt/certbot-apache/certbot-apache-0.18.1.ebuild
parentapp-crypt/certbot-nginx: 0.18.1 bup (diff)
downloadgentoo-da32514f0015c3f8046ffa89463c46d3e9527ac8.tar.gz
gentoo-da32514f0015c3f8046ffa89463c46d3e9527ac8.tar.bz2
gentoo-da32514f0015c3f8046ffa89463c46d3e9527ac8.zip
app-crypt/certbot-apache: 0.18.1 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-0.18.1.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.18.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-0.18.1.ebuild b/app-crypt/certbot-apache/certbot-apache-0.18.1.ebuild
new file mode 100644
index 000000000000..93bc95551953
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.18.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}