summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-21 11:17:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-21 11:18:25 -0500
commit1371f22e41a9604d1f3fcc37893786458d732977 (patch)
treed2d0fa4614c4b45a31604d952b20cfb91d0f3d8f /app-crypt/certbot-apache/certbot-apache-0.18.2.ebuild
parentapp-crypt/certbot: bup (fixes pycrypto use) (diff)
downloadgentoo-1371f22e41a9604d1f3fcc37893786458d732977.tar.gz
gentoo-1371f22e41a9604d1f3fcc37893786458d732977.tar.bz2
gentoo-1371f22e41a9604d1f3fcc37893786458d732977.zip
app-crypt/certbot-apache: 0.18.2 bup, fixes pycrypto bug
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-0.18.2.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.18.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-0.18.2.ebuild b/app-crypt/certbot-apache/certbot-apache-0.18.2.ebuild
new file mode 100644
index 000000000000..93bc95551953
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.18.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}