summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-09-09 23:32:49 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-09-09 23:34:08 -0500
commit9d3ebc9d9026db705a320e3b9e80df44c9e63ecd (patch)
tree9b2afb4980eb084ed5fc3d49787f4e885b4845b0 /app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild
parentapp-crypt/certbot: 1.8.0 bump (diff)
downloadgentoo-9d3ebc9d9026db705a320e3b9e80df44c9e63ecd.tar.gz
gentoo-9d3ebc9d9026db705a320e3b9e80df44c9e63ecd.tar.bz2
gentoo-9d3ebc9d9026db705a320e3b9e80df44c9e63ecd.zip
app-crypt/certbot-apache: 1.8.0 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild
new file mode 100644
index 000000000000..323d9f35ff3a
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-1.6.0[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die
+}