summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-04-19 13:30:46 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-04-19 13:31:05 -0500
commit58a4db8536f7b5ae401fba9db91a9f8401e043ed (patch)
treecbe1107acc3dbae85a196f9022e7247ddf54773a /app-crypt/certbot-apache
parentdev-python/python-augeas: 1.1.0 bump (diff)
downloadgentoo-58a4db8536f7b5ae401fba9db91a9f8401e043ed.tar.gz
gentoo-58a4db8536f7b5ae401fba9db91a9f8401e043ed.tar.bz2
gentoo-58a4db8536f7b5ae401fba9db91a9f8401e043ed.zip
app-crypt/certbot-apache: fix tests (use pytest instead of nose)
pytest is what upstream uses, so use it here too Closes: https://bugs.gentoo.org/718130 Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-apache')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild (renamed from app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild)4
-rw-r--r--app-crypt/certbot-apache/certbot-apache-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild
index d454271a63c7..3ef09260e724 100644
--- a/app-crypt/certbot-apache/certbot-apache-1.3.0.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-1.3.0-r1.ebuild
@@ -31,9 +31,9 @@ RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/pytest[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- nosetests || die
+ esetup.py test || die
}
diff --git a/app-crypt/certbot-apache/certbot-apache-9999.ebuild b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
index 56e71bffc582..499084cf93b1 100644
--- a/app-crypt/certbot-apache/certbot-apache-9999.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
@@ -31,9 +31,9 @@ RDEPEND=">=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/pytest[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- nosetests || die
+ esetup.py test || die
}