summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-03-08 08:56:53 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-03-08 08:57:23 -0600
commit8485dcf6720e4925d5cdbab564eb0a6791b3f8bd (patch)
tree22d23477039ffe1b0d2c7e0271b4c38dee0bae83 /app-crypt/certbot-nginx/certbot-nginx-0.22.0.ebuild
parentapp-crypt/certbot-apache: 0.22.0 bup (diff)
downloadgentoo-8485dcf6720e4925d5cdbab564eb0a6791b3f8bd.tar.gz
gentoo-8485dcf6720e4925d5cdbab564eb0a6791b3f8bd.tar.bz2
gentoo-8485dcf6720e4925d5cdbab564eb0a6791b3f8bd.zip
app-crypt/certbot-nginx: 0.21.1 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-crypt/certbot-nginx/certbot-nginx-0.22.0.ebuild')
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-0.22.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.22.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.22.0.ebuild
new file mode 100644
index 000000000000..dd9e6e8b4372
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-0.22.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=app-crypt/certbot-0.21.1[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.21.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"