summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-02 10:31:26 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-02 10:31:41 -0500
commita66e845a94edb4e604c3aaf95ef294ed2df41dfe (patch)
treea4b149dd9bf3339a2f39646eaf3079e1bd35cd97 /app-crypt/certbot-nginx
parentapp-crypt/certbot-apache: 1.16.0 bump (diff)
downloadgentoo-a66e845a94edb4e604c3aaf95ef294ed2df41dfe.tar.gz
gentoo-a66e845a94edb4e604c3aaf95ef294ed2df41dfe.tar.bz2
gentoo-a66e845a94edb4e604c3aaf95ef294ed2df41dfe.zip
app-crypt/certbot-nginx: 1.16.0 bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-nginx')
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.16.0.ebuild32
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-9999.ebuild4
3 files changed, 35 insertions, 2 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 1ff3acbfcb25..2639edb85c3d 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,3 +1,4 @@
DIST certbot-1.13.0.tar.gz 1426058 BLAKE2B 661aeb430e468a46362c537efd253bb581c7e94b32c67131ae951a67b14d8b6d0f806b7c66a7f60375bb5fe95c714e1b58d3c811d5e0ee21e371b1ff611f74a8 SHA512 1c88027a2259ef9cfb852dd5bd0d326de52d8d7bcec984ee50dc7e5dfe60e2ea68b50afa255b95b2cac08f51467d6584d5671f2410b112b50ce5e4312969ad48
DIST certbot-1.14.0.tar.gz 1415709 BLAKE2B db06b380f70eb6e674d935870582489a722fb8b38fba7535a642200dd6a9d036f55742286129266556f6313e232b2a45003b17f7c34e5f7087b6ab14261a8132 SHA512 39ae44374cdbac11c544d4d3194debf4f98c8d8459138a650ab276f59c84e8c8d738bdc056d444506a326280c1f9fb84356a9a8f4fa6a138d701bdf792b817e5
DIST certbot-1.15.0.tar.gz 1379695 BLAKE2B 002fe05d7ba0bdcb142b57ef2ce6cae4d3e69603f253af6be6e8381311e4962a4c51ef0212d1dfc151af5b40a27a13c22bfff261dead5f8c5bc0ade7f595ca28 SHA512 373447e150974cb1d72cb4eaffe6a8563ce7a43cdd84286bd11dab69d83f52f2736b6538cf5d38c10f7af838437124da9f2de71b6819fcf9347230df05df8259
+DIST certbot-1.16.0.tar.gz 1384177 BLAKE2B 4e46e7d7b9db2f6ef19fab60c2d904f84b502d2911ed496967bbe272db5352c1e9bdb65b8f45358f222214bce4721ceecc12c018b875148bc897f83c5eb63933 SHA512 c2a0c4ea52ab241e387d686a9e5ed67aa5e8b4b7d34ad8996e34562e036c25ab8b397bf482a856758ca787b97bbd78c890189250c0c3d948f03fbf91aa25ece0
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.16.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.16.0.ebuild
new file mode 100644
index 000000000000..b4f61386b477
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.16.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.0[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
diff --git a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
index 52c50cecd71f..b4f61386b477 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
@@ -25,8 +25,8 @@ SLOT="0"
IUSE=""
RDEPEND="
- >=app-crypt/acme-1.4.0[${PYTHON_USEDEP}]
- >=app-crypt/certbot-1.6.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.2.0[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"