summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-11-03 10:36:31 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-11-03 10:36:52 -0500
commitb0c7f923bf9eeff4abe3ccca178dfca132e9ab80 (patch)
treefeb39dcefb26acf62da73ce996999f91ce9baa1a /app-crypt/certbot-nginx
parentapp-crypt/certbot-apache: 1.21.0 bump (diff)
downloadgentoo-b0c7f923bf9eeff4abe3ccca178dfca132e9ab80.tar.gz
gentoo-b0c7f923bf9eeff4abe3ccca178dfca132e9ab80.tar.bz2
gentoo-b0c7f923bf9eeff4abe3ccca178dfca132e9ab80.zip
app-crypt/certbot-nginx: 1.21.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-nginx')
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.21.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index d2519ac78a81..b967cab77644 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,3 +1,4 @@
DIST certbot-1.18.0.tar.gz 1332615 BLAKE2B eb086710b943893025d6e1091470ca02de074232372f4c9fa21fa83a347fe54df988b9553c8cf6afd6e166b8c464d595171984c984008a872e16c0179bb774b2 SHA512 94b16ba0586e0f5d3036280c68f9976c25889ca48fbbe7aded41f0d9feba2300a3f0ff8fe321b39d8642bcdd874c7332cf2acb3187b5869fe415831f58a75a7b
DIST certbot-1.19.0.tar.gz 1338653 BLAKE2B b6ed909da2aed9853cf3dc6b936c513f33a127548ee30ac45a32a682141c5e4e79401ea328b7caf4e28d1d85aa2a9831e93deaa26c93216708a33be465dc8387 SHA512 2c1beb8c06299b9003fafd970cd3e977db85c4e84f1bf710166b7a99035b5c43a2a222d8d51513ac595255dd8eda02a1fb834c01ce68921927715c880052536e
DIST certbot-1.20.0.tar.gz 1339066 BLAKE2B 01278a53ea7166037c039d270ddd11a10c0570a9f038571dc6791e51f214fbff1589371b40c0dc73cbc18ed2005cfc231452bd00b039841a09ddb3c65d4ab122 SHA512 d35b2574811ac896ad119355be3a901438400e81a67388bd93290c4e7e9f6fa60dad99b51bc9bac7a7ac60714ed8bb6f60f522ce1a1a169886d0a15f0d0e371b
+DIST certbot-1.21.0.tar.gz 1343180 BLAKE2B 79bbaafe96bca4cee9aabb39f4e9f1f12be4d2e1d9c1b156966061606ac3b07e5d80c5053baa03698e5513477076ca8f604aff43f77ee7f45d70d4b88429a875 SHA512 11ea781c5113cf68e3a76cafc2cf38d5ebc9cdb2f40a79eae0cdeac5d40f8dac05a4c71a269d5a6ff78027a1db0676195a8413e28a87d00aaf1602f6f2ce5b5e
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.21.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.21.0.ebuild
new file mode 100644
index 000000000000..45a8976cfe34
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.21.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.0[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest