summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-25 14:39:33 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-25 14:39:33 +0200
commit7807997ef517b71b881a9f3c695bc731ace32a3e (patch)
treec91bf64e70fac60fb59fb135ff9f0b6d72e21240 /app-crypt/cfssl
parentdev-db/oracle-instantclient: fix lib.so symlinks (diff)
downloadgentoo-7807997ef517b71b881a9f3c695bc731ace32a3e.tar.gz
gentoo-7807997ef517b71b881a9f3c695bc731ace32a3e.tar.bz2
gentoo-7807997ef517b71b881a9f3c695bc731ace32a3e.zip
app-crypt/cfssl: Update snapshot
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'app-crypt/cfssl')
-rw-r--r--app-crypt/cfssl/Manifest1
-rw-r--r--app-crypt/cfssl/cfssl-1.2.0_p20170915.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/cfssl/Manifest b/app-crypt/cfssl/Manifest
index 74f405c7a7f0..a5e2adc08ea1 100644
--- a/app-crypt/cfssl/Manifest
+++ b/app-crypt/cfssl/Manifest
@@ -1 +1,2 @@
DIST cfssl-1.2.0_p20170601.tar.gz 8025105 SHA256 4a9a1a801dd10c7cfbb1e98ce60f8bb0df407282dbbf1e8f75ff55a7909aba6e SHA512 f89d6b142eb5286b720c9d94534c474b15738c6a856999588392b37ffa753e0f0c9d663debee9cc216be765d8f39a71872401173a56293cdca2f2d1791c3d758 WHIRLPOOL 44019b727a66758d56c0ee9064a26b8b43d367bef0212f1a50aa8eeaf827a1f09590b4b6eb50ed5fff10b3ad72866526761a8522236fd82e1a5ff3850780254a
+DIST cfssl-1.2.0_p20170915.tar.gz 8027590 SHA256 11c9997eed939fd53237e27cc7d20a422045837315d58f3091449716ce34c4a5 SHA512 247ee892f7785ae11e8b2d38c1fdad0a3bcea9d9e410ce1bc985d15fad65b981c46e317cbb0fe0cacf190dfbbad7b9f8685f6ddd2a24056dd61e621b2cccd232 WHIRLPOOL a4aa35c8cbc0c3531c5b0bb49dc0376ba00603f4c95a686b5e012be409b4d39cdfa3196bf7ca4e0cdd010217d43e68ceb3d403b813dcac064e6b0d1aafc99336
diff --git a/app-crypt/cfssl/cfssl-1.2.0_p20170915.ebuild b/app-crypt/cfssl/cfssl-1.2.0_p20170915.ebuild
new file mode 100644
index 000000000000..17742ad0c2ca
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.2.0_p20170915.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/cloudflare/${PN}"
+EGIT_COMMIT="7d88da830aad9d533c2fb8532da23f6a75331b52"
+inherit golang-build golang-vcs-snapshot
+
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="hardened"
+
+RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src || die
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${S}" go install github.com/cloudflare/cfssl/cmd/... || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ pushd src/${EGO_PN} || die
+ dodoc CHANGELOG README.md
+ popd || die
+}