summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-04-03 16:21:54 +0200
committerSebastian Pipping <sping@gentoo.org>2023-04-03 16:22:04 +0200
commit8cca487e23ee0775316567c7083ca720222f1dcd (patch)
tree680587fa8b2205a5454acd69db3f9f4864d97f88 /app-crypt/debian-archive-keyring/debian-archive-keyring-2023.3.ebuild
parentmail-mta/postfix: add 3.8_pre20230402, drop 3.8_pre20230314 (diff)
downloadgentoo-8cca487e23ee0775316567c7083ca720222f1dcd.tar.gz
gentoo-8cca487e23ee0775316567c7083ca720222f1dcd.tar.bz2
gentoo-8cca487e23ee0775316567c7083ca720222f1dcd.zip
app-crypt/debian-archive-keyring: 2023.3
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-crypt/debian-archive-keyring/debian-archive-keyring-2023.3.ebuild')
-rw-r--r--app-crypt/debian-archive-keyring/debian-archive-keyring-2023.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/debian-archive-keyring/debian-archive-keyring-2023.3.ebuild b/app-crypt/debian-archive-keyring/debian-archive-keyring-2023.3.ebuild
new file mode 100644
index 000000000000..00b2e3a5b143
--- /dev/null
+++ b/app-crypt/debian-archive-keyring/debian-archive-keyring-2023.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="GnuPG archive keys of the Debian archive"
+HOMEPAGE="https://packages.debian.org/sid/debian-archive-keyring"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}_all.deb"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_install() {
+ doins -r .
+
+ # https://bugs.gentoo.org/729142
+ gunzip "${D}"/usr/share/doc/${PN}/changelog.gz || die
+
+ mv "${D}"/usr/share/doc/{${PN},${PF}} || die
+}