summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-07 23:20:12 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-08 11:23:53 -0500
commit1e4e3d89728cc93439b3c72872779f9a88a661bb (patch)
treedfaf7029b9b1e394a3690971904950e1da2b75a2 /app-crypt/gcr
parentmedia-libs/libjpeg-turbo: marked ~{x86,x64}-solaris (diff)
downloadgentoo-1e4e3d89728cc93439b3c72872779f9a88a661bb.tar.gz
gentoo-1e4e3d89728cc93439b3c72872779f9a88a661bb.tar.bz2
gentoo-1e4e3d89728cc93439b3c72872779f9a88a661bb.zip
app-crypt/gcr: Version bump to 3.38.0
Closes: https://bugs.gentoo.org/751346 Closes: https://bugs.gentoo.org/762799 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-crypt/gcr')
-rw-r--r--app-crypt/gcr/Manifest1
-rw-r--r--app-crypt/gcr/files/3.38.0-avoid-gnupg-circular-dep.patch52
-rw-r--r--app-crypt/gcr/files/3.38.0-optional-vapi.patch88
-rw-r--r--app-crypt/gcr/gcr-3.38.0.ebuild84
4 files changed, 225 insertions, 0 deletions
diff --git a/app-crypt/gcr/Manifest b/app-crypt/gcr/Manifest
index 593256ddcdf4..1776e37e7627 100644
--- a/app-crypt/gcr/Manifest
+++ b/app-crypt/gcr/Manifest
@@ -1 +1,2 @@
DIST gcr-3.36.0.tar.xz 1025760 BLAKE2B 03f0d0ed40b600ed80e894111fedff3efcbbaaf6f261d6a44a3649a1acb50c4f35f3dc9a7ddb60f56cab241f68fef83aa5a02a94036e70a6556b35300f2c8fb5 SHA512 0431e7971b73accc62869c9497fcff7c111c453aa6a8ff25b42f19ceae1be0aec52e0e4eb504676f967c6e4f179198c15c521278690822e3457dbc5fe512fd5e
+DIST gcr-3.38.0.tar.xz 1029784 BLAKE2B cf295a9f497d6c54067717e806439166965f90670ed5f7283802bb70c547465d9cc28d452970269d4315d02d24cc31f483a0a1fc1807f9b9720e70aa2b8249b9 SHA512 24c35ac514a67a1dee6a5738e829b55921a490b060ffa597421cea0abac3ddc62695370d2c7b3504c0adfd55b1ade878ad3ca5e6cb869428b4a19f4a11563bc6
diff --git a/app-crypt/gcr/files/3.38.0-avoid-gnupg-circular-dep.patch b/app-crypt/gcr/files/3.38.0-avoid-gnupg-circular-dep.patch
new file mode 100644
index 000000000000..5bb7da0fa787
--- /dev/null
+++ b/app-crypt/gcr/files/3.38.0-avoid-gnupg-circular-dep.patch
@@ -0,0 +1,52 @@
+From b938b0b658852c682ae17d56e0ad9322611e9516 Mon Sep 17 00:00:00 2001
+From: Rasmus Thomsen <oss@cogitri.dev>
+Date: Wed, 11 Mar 2020 11:49:08 +0100
+Subject: [PATCH 1/2] meson: allow building without gpg(2) installed
+
+This avoids circular dependencies, such as gcr -> gpg2 -> pinentry -> gcr
+---
+ meson.build | 7 +++++--
+ meson_options.txt | 5 +++++
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index a26a0f9..02b4c3c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -41,7 +41,10 @@ gobject_dep = dependency('gobject-2.0', version: '>=' + min_glib_version)
+ gio_dep = dependency('gio-2.0', version: '>=' + min_glib_version)
+ gio_unix_dep = dependency('gio-unix-2.0',version: '>=' + min_glib_version)
+ glib_deps = [ glib_dep, gmodule_dep, gthread_dep, gobject_dep, gio_dep, gio_unix_dep, ]
+-gpg_bin = find_program('gpg2', 'gpg')
++gpg_path = get_option('gpg_path')
++if gpg_path == ''
++ gpg_path = find_program('gpg2', 'gpg').path()
++endif
+ libgcrypt_dep = dependency('libgcrypt', version: '>= 1')
+ p11kit_dep = dependency('p11-kit-1', version: '>= 0.19.0')
+ p11_system_config_modules = p11kit_dep.get_pkgconfig_variable('p11_system_config_modules')
+@@ -65,7 +68,7 @@ conf.set('HAVE_GETTEXT', true)
+ conf.set('HAVE_LOCALE_H', cc.has_header('locale.h'))
+ conf.set('HAVE_TIMEGM', cc.has_function('timegm'))
+ conf.set('HAVE_MLOCK', cc.has_function('mlock'))
+-conf.set_quoted('GPG_EXECUTABLE', gpg_bin.path())
++conf.set_quoted('GPG_EXECUTABLE', gpg_path)
+ conf.set_quoted('LIBGCRYPT_VERSION', libgcrypt_dep.version())
+ config_file = configure_file(
+ output: 'config.h',
+diff --git a/meson_options.txt b/meson_options.txt
+index bbdc8e3..ae0f524 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -13,3 +13,8 @@ option('gtk_doc',
+ value: true,
+ description: 'Build the reference documentation (requires gtk-doc)',
+ )
++option('gpg_path',
++ type: 'string',
++ value: '',
++ description: 'Path to gpg, autodetected if not set',
++)
+--
+2.26.2
+
diff --git a/app-crypt/gcr/files/3.38.0-optional-vapi.patch b/app-crypt/gcr/files/3.38.0-optional-vapi.patch
new file mode 100644
index 000000000000..d565884994fd
--- /dev/null
+++ b/app-crypt/gcr/files/3.38.0-optional-vapi.patch
@@ -0,0 +1,88 @@
+From 6d61774b8556eb4acfa5e7613ee25893d2a7e565 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Tue, 18 Aug 2020 09:36:19 +0300
+Subject: [PATCH 2/2] build: Make vapi optional
+
+---
+ gck/meson.build | 2 ++
+ gcr/meson.build | 2 ++
+ meson_options.txt | 5 +++++
+ ui/meson.build | 2 ++
+ 4 files changed, 11 insertions(+)
+
+diff --git a/gck/meson.build b/gck/meson.build
+index 756b486..a15f4ed 100644
+--- a/gck/meson.build
++++ b/gck/meson.build
+@@ -142,6 +142,7 @@ if get_option('introspection')
+ install: true,
+ )
+
++if get_option('vapi')
+ gck_vapi = gnome.generate_vapi('gck-@0@'.format(gck_major_version),
+ sources: gck_gir[0],
+ metadata_dirs: meson.current_source_dir(),
+@@ -153,6 +154,7 @@ if get_option('introspection')
+ install_dir: get_option('datadir') / 'vala' / 'vapi',
+ )
+ endif
++endif
+
+ # pkg-config file
+ pkgconfig.generate(gck_lib,
+diff --git a/gcr/meson.build b/gcr/meson.build
+index 06c3a63..cc642cf 100644
+--- a/gcr/meson.build
++++ b/gcr/meson.build
+@@ -204,6 +204,7 @@ if get_option('introspection')
+ install: true,
+ )
+
++if get_option('vapi')
+ gcr_vapi = gnome.generate_vapi('gcr-@0@'.format(gcr_major_version),
+ sources: gcr_gir[0],
+ packages: [ 'glib-2.0', 'gio-2.0', gck_vapi ],
+@@ -217,6 +218,7 @@ if get_option('introspection')
+ install: true,
+ )
+ endif
++endif
+
+ # pkg-config file
+ pkgconfig.generate(gcr_base_lib,
+diff --git a/meson_options.txt b/meson_options.txt
+index ae0f524..f68cb95 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -18,3 +18,8 @@ option('gpg_path',
+ value: '',
+ description: 'Path to gpg, autodetected if not set',
+ )
++option('vapi',
++ type: 'boolean',
++ value: true,
++ description: 'Generate vapi data (requires vapigen and introspection option)',
++)
+diff --git a/ui/meson.build b/ui/meson.build
+index 477412d..0b89b24 100644
+--- a/ui/meson.build
++++ b/ui/meson.build
+@@ -169,6 +169,7 @@ if get_option('introspection')
+ install: true,
+ )
+
++if get_option('vapi')
+ gcr_ui_vapi = gnome.generate_vapi('gcr-ui-@0@'.format(gcr_major_version),
+ sources: gcr_ui_gir[0],
+ packages: [
+@@ -190,6 +191,7 @@ if get_option('introspection')
+ install: true,
+ )
+ endif
++endif
+
+ # gcr-viewer
+ gcr_viewer = executable('gcr-viewer',
+--
+2.26.2
+
diff --git a/app-crypt/gcr/gcr-3.38.0.ebuild b/app-crypt/gcr/gcr-3.38.0.ebuild
new file mode 100644
index 000000000000..1328f530c41d
--- /dev/null
+++ b/app-crypt/gcr/gcr-3.38.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gcr"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/1" # subslot = suffix of libgcr-base-3 and co
+
+IUSE="gtk gtk-doc +introspection test +vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+DEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libgcrypt-1.2.2:0=
+ >=app-crypt/p11-kit-0.19.0
+ gtk? ( >=x11-libs/gtk+-3.12:3[X,introspection?] )
+ >=sys-apps/dbus-1
+ introspection? ( >=dev-libs/gobject-introspection-1.58:= )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="app-crypt/gnupg"
+BDEPEND="
+ ${PYTHON_DEPS}
+ gtk? ( dev-libs/libxml2:2 )
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ >=sys-devel/gettext-0.19.8
+ test? ( app-crypt/gnupg )
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-avoid-gnupg-circular-dep.patch
+ "${FILESDIR}"/${PV}-optional-vapi.patch
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_use gtk)
+ $(meson_use gtk-doc gtk_doc)
+ -Dgpg_path="${EPREFIX}"/usr/bin/gpg
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}