summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-14 23:00:49 +0000
committerSam James <sam@gentoo.org>2023-02-14 23:03:52 +0000
commitadea75f20d8c06b9708d5a7d6f53a07d91360c7d (patch)
tree15b425db817ff761752fa18e76c699b54aea2178 /app-crypt/gpgstats
parentdev-python/django: Remove old (diff)
downloadgentoo-adea75f20d8c06b9708d5a7d6f53a07d91360c7d.tar.gz
gentoo-adea75f20d8c06b9708d5a7d6f53a07d91360c7d.tar.bz2
gentoo-adea75f20d8c06b9708d5a7d6f53a07d91360c7d.zip
app-crypt/gpgstats: fix build w/ clang 16
No patch as upstream is 404, apparently. Closes: https://bugs.gentoo.org/894350 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/gpgstats')
-rw-r--r--app-crypt/gpgstats/gpgstats-0.5-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-crypt/gpgstats/gpgstats-0.5-r2.ebuild b/app-crypt/gpgstats/gpgstats-0.5-r2.ebuild
index 85f24aeaccea..860db1e0ed25 100644
--- a/app-crypt/gpgstats/gpgstats-0.5-r2.ebuild
+++ b/app-crypt/gpgstats/gpgstats-0.5-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="GPGstats calculates statistics on the keys in your key-ring"
HOMEPAGE="http://www.vanheusden.com/gpgstats/"
@@ -19,6 +19,9 @@ DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${P}-flags.patch )
src_compile() {
+ # Uses removed 'register' keyword, bug #894350
+ append-cxxflags -std=c++14
+
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" DEBUG=
}