summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-07 10:43:36 -0700
committerMatt Turner <mattst88@gentoo.org>2019-09-07 10:43:47 -0700
commite70738af90b64fbad95b188c0b405ca6123416f9 (patch)
tree764fa59bd1e743606cfa2796628ffe6e99771a11 /app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
parentsys-fs/ecryptfs-utils: Drop old versions (diff)
downloadgentoo-e70738af90b64fbad95b188c0b405ca6123416f9.tar.gz
gentoo-e70738af90b64fbad95b188c0b405ca6123416f9.tar.bz2
gentoo-e70738af90b64fbad95b188c0b405ca6123416f9.zip
app-crypt/ima-evm-utils: Use slot operator for sys-apps/keyutils
Closes: https://bugs.gentoo.org/693224 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild')
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
new file mode 100644
index 000000000000..93152d948962
--- /dev/null
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Supporting tools for IMA and EVM"
+HOMEPAGE="http://linux-ima.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-ima/${P}.tar.gz"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ sys-apps/keyutils:="
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1-configure-use-sys-xattr-bug-649790.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i '/^MANPAGE_DOCBOOK_XSL/s:/usr/share/xml/docbook/stylesheet/docbook-xsl/manpages/docbook.xsl:/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}