summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-15 06:10:37 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-04-15 06:10:53 +1000
commit352f3ac4a9c1db8173d065dc5cbba147fdadd419 (patch)
tree58acbf50f7731e535f003ef4b1ac46478fdf8815 /app-crypt/kencfs/kencfs-1.6.2.ebuild
parentapp-admin/cli53: add src_test (diff)
downloadgentoo-352f3ac4a9c1db8173d065dc5cbba147fdadd419.tar.gz
gentoo-352f3ac4a9c1db8173d065dc5cbba147fdadd419.tar.bz2
gentoo-352f3ac4a9c1db8173d065dc5cbba147fdadd419.zip
app-crypt/kencfs: version bump
Gentoo-bug: 579842 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-crypt/kencfs/kencfs-1.6.2.ebuild')
-rw-r--r--app-crypt/kencfs/kencfs-1.6.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/kencfs/kencfs-1.6.2.ebuild b/app-crypt/kencfs/kencfs-1.6.2.ebuild
new file mode 100644
index 000000000000..c0ca99e09834
--- /dev/null
+++ b/app-crypt/kencfs/kencfs-1.6.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="GUI frontend for encfs"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=134003"
+SRC_URI="http://kde-apps.org/CONTENT/content-files/134003-${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ kde-base/kdelibs:4
+"
+RDEPEND="${DEPEND}
+ kde-apps/kwalletd:4
+ sys-fs/encfs
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.0-encfs5.patch"
+ "${FILESDIR}/${PN}-1.6.2-desktop.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i ${PN}.pro -e "/^doc.path =/s/${PN}/${PF}/" \
+ || die "sed docdir failed"
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}