summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2015-11-24 22:45:08 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2015-11-24 22:47:19 -0700
commita91a1c1e32d9ea4dce70f8e5a673cecce8034198 (patch)
tree5c898fec67a9f60527bf97637f16657d00cba814 /app-crypt/keybase/keybase-0.8.24.ebuild
parentapp-emulation/xen-tools: bump seabios, fix sdl bug (diff)
downloadgentoo-a91a1c1e32d9ea4dce70f8e5a673cecce8034198.tar.gz
gentoo-a91a1c1e32d9ea4dce70f8e5a673cecce8034198.tar.bz2
gentoo-a91a1c1e32d9ea4dce70f8e5a673cecce8034198.zip
app-crypt/keybase: Version bump
See Bug 566768. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-crypt/keybase/keybase-0.8.24.ebuild')
-rw-r--r--app-crypt/keybase/keybase-0.8.24.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/keybase/keybase-0.8.24.ebuild b/app-crypt/keybase/keybase-0.8.24.ebuild
new file mode 100644
index 000000000000..644ff738ea67
--- /dev/null
+++ b/app-crypt/keybase/keybase-0.8.24.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Client for keybase.io"
+HOMEPAGE="https://keybase.io/"
+SRC_URI="https://github.com/keybase/node-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-libs/nodejs
+ app-crypt/gnupg"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mv "node-client-${PV}" "${P}"
+}
+
+src_install() {
+ dodoc CHANGELOG.md README.md SIGNED.md
+ insinto "/opt/${PN}"
+ doins -r package.json bin certs json lib node_modules sql
+ dosym "${D}/opt/${PN}/bin/main.js" "${ROOT}/usr/bin/keybase"
+ chmod 0755 "${D}/opt/${PN}/bin/main.js" || die
+}